summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scikit-learn/scikit-learn-0.22.2_p1.ebuild')
-rw-r--r--dev-python/scikit-learn/scikit-learn-0.22.2_p1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/scikit-learn/scikit-learn-0.22.2_p1.ebuild b/dev-python/scikit-learn/scikit-learn-0.22.2_p1.ebuild
new file mode 100644
index 000000000000..c67f8b4796ed
--- /dev/null
+++ b/dev-python/scikit-learn/scikit-learn-0.22.2_p1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+MY_PV="${PV//_p/.post}"
+DESCRIPTION="Machine learning library for Python"
+HOMEPAGE="https://scikit-learn.org/stable/
+ https://github.com/scikit-learn/scikit-learn"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pushd "${TEST_DIR}/lib" >/dev/null || die
+ pytest -vv || die "testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}