summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/storm')
-rw-r--r--dev-python/storm/Manifest1
-rw-r--r--dev-python/storm/metadata.xml8
-rw-r--r--dev-python/storm/storm-0.20-r1.ebuild65
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/storm/Manifest b/dev-python/storm/Manifest
new file mode 100644
index 000000000000..3361beec202f
--- /dev/null
+++ b/dev-python/storm/Manifest
@@ -0,0 +1 @@
+DIST storm-0.20.tar.bz2 213069 SHA256 1fe016c9ec40520eafc3cf359f1ec2b7fa86be91e45c9279bfb0ea3b06390a82 SHA512 7a22c6a6fa45f7bbeeb5c6f934d6f889a6d90d78a6d3e3b9c6a6825485ec35301f573d08c619693a2587e795582db633254631c0be7cd8f1fee6b03a88378a8d WHIRLPOOL e18fb39e127eedd0f7691fc9b3c043b79da02beaab8088dc1f461cfdd23c91034ae6dbf3450a778ea2e06b93239463d5813015f5b6b6901f775da38b4188d2b1
diff --git a/dev-python/storm/metadata.xml b/dev-python/storm/metadata.xml
new file mode 100644
index 000000000000..eb2ab1aa0af2
--- /dev/null
+++ b/dev-python/storm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="launchpad">storm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/storm/storm-0.20-r1.ebuild b/dev-python/storm/storm-0.20-r1.ebuild
new file mode 100644
index 000000000000..dc45516f8916
--- /dev/null
+++ b/dev-python/storm/storm-0.20-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1
+
+DESCRIPTION="An object-relational mapper for Python developed at Canonical"
+HOMEPAGE="https://storm.canonical.com/ http://pypi.python.org/pypi/storm"
+SRC_URI="http://launchpad.net/storm/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql postgres sqlite test"
+
+RDEPEND="mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( =dev-python/psycopg-2*[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/fixtures[${PYTHON_USEDEP}] )"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+DOCS="tests/tutorial.txt"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+python_prepare_all() {
+ sed -e "s:find_packages():find_packages(exclude=['tests','tests.*']):" \
+ -i setup.py || die
+
+ # delete rogue errors in setting exceptions
+ sed -e '/module_exception is not None:/d' \
+ -e '/module_exception.__bases__ += (exception,)/d' \
+ -i storm/exceptions.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if use mysql; then
+ elog "To run the MySQL-tests, you need:"
+ elog " - a running mysql-server"
+ elog " - an already existing database 'db'"
+ elog " - a user 'user' with full permissions on that database"
+ elog " - and an environment variable STORM_MYSQL_URI=\"mysql://user:password@host:1234/db\""
+ fi
+ if use postgres; then
+ elog "To run the PostgreSQL-tests, you need:"
+ elog " - a running postgresql-server"
+ elog " - an already existing database 'db'"
+ elog " - a user 'user' with full permissions on that database"
+ elog " - and an environment variable STORM_POSTGRES_URI=\"postgres://user:password@host:1234/db\""
+ fi
+
+ # Some tests require a server instance which is absent
+ "${PYTHON}" test --verbose || die
+}