summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/coffee-rails/coffee-rails-4.1.1-r2.ebuild')
-rw-r--r--dev-ruby/coffee-rails/coffee-rails-4.1.1-r2.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-ruby/coffee-rails/coffee-rails-4.1.1-r2.ebuild b/dev-ruby/coffee-rails/coffee-rails-4.1.1-r2.ebuild
deleted file mode 100644
index 20d309d0a069..000000000000
--- a/dev-ruby/coffee-rails/coffee-rails-4.1.1-r2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Coffee Script adapter for the Rails asset pipeline"
-HOMEPAGE="https://github.com/rails/coffee-rails"
-SRC_URI="https://github.com/rails/coffee-rails/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux"
-
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/coffee-script-2.2.0
- >dev-ruby/railties-4:* <dev-ruby/railties-5.1:*"
-
-all_ruby_prepare() {
- # Avoid dependency on git and bundler.
- sed -i -e 's/git ls-files/echo/' \
- -e '/bundler/I s:^:#:' Rakefile || die
-
- # Make sure a consistent rails version is loaded.
- sed -i -e '4igem "rails"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
-}