summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/xpilot')
-rw-r--r--games-action/xpilot/Manifest1
-rw-r--r--games-action/xpilot/metadata.xml8
-rw-r--r--games-action/xpilot/xpilot-4.5.5.ebuild53
3 files changed, 62 insertions, 0 deletions
diff --git a/games-action/xpilot/Manifest b/games-action/xpilot/Manifest
new file mode 100644
index 000000000000..042b4d8bcfa5
--- /dev/null
+++ b/games-action/xpilot/Manifest
@@ -0,0 +1 @@
+DIST xpilot-4.5.5.tar.bz2 1115502 SHA256 5e40424d093c8b712170a5dff3396df63302775f42da829b8832840f359cd92a SHA512 002fbdbee3035e21f441d749d68ac41da2816a691e1c0d1cf9de9cddaa479c92da57eb36081884b9908a6ae83454f6f532c24c89280d27e2cbf9570442ef301c WHIRLPOOL eebaf2fc0aab431ca94f627aa59d38bf708d3e905e6c502381643c239247397eb8cc6131867c84245e0455caabbc874b738d41402c7832045ab250cda7a1de6d
diff --git a/games-action/xpilot/metadata.xml b/games-action/xpilot/metadata.xml
new file mode 100644
index 000000000000..d35614714d1e
--- /dev/null
+++ b/games-action/xpilot/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">xpilotgame</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/xpilot/xpilot-4.5.5.ebuild b/games-action/xpilot/xpilot-4.5.5.ebuild
new file mode 100644
index 000000000000..33fff37ffb4f
--- /dev/null
+++ b/games-action/xpilot/xpilot-4.5.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A multi-player 2D client/server space game"
+HOMEPAGE="http://www.xpilot.org/"
+SRC_URI="mirror://sourceforge/xpilotgame/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-misc/gccmakedep
+ x11-misc/imake
+ app-text/rman"
+
+src_prepare() {
+ sed -i \
+ -e '/^INSTMAN/s:=.*:=/usr/share/man/man6:' \
+ -e "/^INSTLIB/s:=.*:=${GAMES_DATADIR}/${PN}:" \
+ -e "/^INSTBIN/s:=.*:=${GAMES_BINDIR}:" \
+ Local.config || die
+ # work with glibc-2.20
+ sed -i \
+ -e 's/getline/lgetline/' \
+ src/client/textinterface.c || die
+}
+
+src_compile() {
+ xmkmf || die
+ emake Makefiles
+ emake includes
+ emake depend
+ emake CC="${CC}" CDEBUGFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" install.man
+ newicon lib/textures/logo.ppm ${PN}.ppm
+ make_desktop_entry ${PN} XPilot /usr/share/pixmaps/${PN}.ppm
+ dodoc README.txt doc/{ChangeLog,CREDITS,FAQ,README*,TODO}
+ prepgamesdirs
+}