summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/xdx/xdx-2.5.0.ebuild')
-rw-r--r--media-radio/xdx/xdx-2.5.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-radio/xdx/xdx-2.5.0.ebuild b/media-radio/xdx/xdx-2.5.0.ebuild
new file mode 100644
index 000000000000..b81c45eabef7
--- /dev/null
+++ b/media-radio/xdx/xdx-2.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="a GTK+ TCP/IP DX-cluster and ON4KST chat client"
+HOMEPAGE="http://sourceforge.net/projects/xdxclusterclient"
+SRC_URI="mirror://sourceforge/xdxclusterclient/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ elog "To use the rig control feature, install media-libs/hamlib"
+ elog "and enable hamlib in the Preferences dialog. (no need for recompile)"
+}