summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ipx-utils')
-rw-r--r--net-misc/ipx-utils/Manifest1
-rw-r--r--net-misc/ipx-utils/files/ipx-utils-1.1-makefile.patch24
-rw-r--r--net-misc/ipx-utils/files/ipx-utils-1.1-proc.patch13
-rw-r--r--net-misc/ipx-utils/files/ipx.confd27
-rw-r--r--net-misc/ipx-utils/files/ipx.init43
-rw-r--r--net-misc/ipx-utils/ipx-utils-1.1-r3.ebuild34
-rw-r--r--net-misc/ipx-utils/metadata.xml8
7 files changed, 150 insertions, 0 deletions
diff --git a/net-misc/ipx-utils/Manifest b/net-misc/ipx-utils/Manifest
new file mode 100644
index 000000000000..9beeb5817b87
--- /dev/null
+++ b/net-misc/ipx-utils/Manifest
@@ -0,0 +1 @@
+DIST ipx-1.1.tar.gz 8177 SHA256 c59c3dbb8cfb8ef5b3cb76a302d5f38254e9dbbbd99fae3f048e3751605d7fb8 SHA512 cb1bcf0c28939ab5ff1e1cf36f1cb8cbfcb7c019d65df5fc56a1b43673406cdf4abffa3d6164615e42ce955f078c05f721da90ca54353870e552c01bb3c2973d WHIRLPOOL 829715dd9e0b3d1cf7ee5443fe3081bf2534b4f5e85ea096f0cf722d94e068c53141a3504ac9dc51457747d4038e249bd187dced1d07cb867fd106575ae07d65
diff --git a/net-misc/ipx-utils/files/ipx-utils-1.1-makefile.patch b/net-misc/ipx-utils/files/ipx-utils-1.1-makefile.patch
new file mode 100644
index 000000000000..5a596f818d19
--- /dev/null
+++ b/net-misc/ipx-utils/files/ipx-utils-1.1-makefile.patch
@@ -0,0 +1,24 @@
+--- ipx-1.1.orig/Makefile
++++ ipx-1.1/Makefile
+@@ -10,17 +10,8 @@ clean:
+ install: $(UTILS)
+ for i in $(UTILS); \
+ do \
+- install --strip $$i /sbin; \
+- install $$i.8 /usr/man/man8; \
++ install $$i ${DESTDIR}/sbin; \
++ install $$i.8 ${DESTDIR}/usr/share/man/man8; \
+ done
+- install init.ipx /etc/rc.d/init.d/ipx
+- install -m 0644 config.ipx /etc/sysconfig/ipx
+- rm -f /etc/rc.d/rc2.d/S15ipx
+- ln -sf /etc/rc.d/init.d/ipx /etc/rc.d/rc2.d/S15ipx
+- rm -f /etc/rc.d/rc3.d/S15ipx
+- ln -sf /etc/rc.d/init.d/ipx /etc/rc.d/rc3.d/S15ipx
+- rm -f /etc/rc.d/rc5.d/S15ipx
+- ln -sf /etc/rc.d/init.d/ipx /etc/rc.d/rc5.d/S15ipx
+- rm -f /etc/rc.d/rc6.d/K55ipx
+- ln -sf /etc/rc.d/init.d/ipx /etc/rc.d/rc6.d/K55ipx
+-
++# install init.ipx /etc/rc.d/init.d/ipx
++# install -m 0644 config.ipx /etc/sysconfig/ipx
diff --git a/net-misc/ipx-utils/files/ipx-utils-1.1-proc.patch b/net-misc/ipx-utils/files/ipx-utils-1.1-proc.patch
new file mode 100644
index 000000000000..d82d228ff139
--- /dev/null
+++ b/net-misc/ipx-utils/files/ipx-utils-1.1-proc.patch
@@ -0,0 +1,13 @@
+--- ipx-1.1/ipx_interface.c.orig 2004-10-16 13:14:40.677964152 -0400
++++ ipx-1.1/ipx_interface.c 2004-10-16 13:15:18.464219768 -0400
+@@ -191,7 +191,9 @@
+ exit(-1);
+ }
+
+- fp = fopen("/proc/net/ipx_interface", "r");
++ fp = fopen("/proc/net/ipx/interface", "r");
++ if (fp == NULL)
++ fp = fopen("/proc/net/ipx_interface", "r");
+ if (fp == NULL) {
+ fprintf(stderr,
+ "%s: Unable to open \"/proc/net/ipx_interface.\"\n",
diff --git a/net-misc/ipx-utils/files/ipx.confd b/net-misc/ipx-utils/files/ipx.confd
new file mode 100644
index 000000000000..d061d0d0de83
--- /dev/null
+++ b/net-misc/ipx-utils/files/ipx.confd
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Config file for /etc/init.d/ipx
+
+# Automatically selecting a primary interface.
+IPX_AUTO_PRIMARY=on
+
+# Automatically creating interfaces.
+IPX_AUTO_INTERFACE=on
+
+# Interface to which IPX sockets are bound.
+IPX_DEVICE=eth0
+
+# The IPX frame type to use
+IPX_FRAME=802.2
+
+# Create a special kind of IPX interface that does not
+# have a physical device or frame type.
+IPX_INTERNAL_NET=no
+
+# Network number
+IPX_NETNUM=1
+
+# Node number
+IPX_NODENUM=1
diff --git a/net-misc/ipx-utils/files/ipx.init b/net-misc/ipx-utils/files/ipx.init
new file mode 100644
index 000000000000..091c9d8de706
--- /dev/null
+++ b/net-misc/ipx-utils/files/ipx.init
@@ -0,0 +1,43 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+#NB: Config is in /etc/conf.d/ipx
+
+depend() {
+ use net
+}
+
+start() {
+ local retval=0
+
+ ebegin "Bringing IPX up"
+ if [ ${IPX_INTERNAL_NET} = "yes" ]
+ then
+ /sbin/ipx_internal_net add ${IPX_NETNUM} ${IPX_NODENUM}
+ retval=$?
+ else
+ /sbin/ipx_interface add -p ${IPX_DEVICE} \
+ ${IPX_FRAME} ${IPX_NETNUM}
+ retval=$?
+ fi
+
+ ipx_configure \
+ --auto_primary=${IPX_AUTO_PRIMARY} \
+ --auto_interface=${IPX_AUTO_INTERFACE}
+ retval=$(( $retval + $? ))
+ eend ${retval} "Failed to bring IPX up"
+}
+
+stop() {
+ local retval=0
+
+ ebegin "Bringing IPX down"
+ /bin/umount -v -a -tncpfs
+ /sbin/ipx_configure --auto_primary=off --auto_interface=off
+ retval=$?
+ /sbin/ipx_interface delall
+ retval=$(( $retval + $? ))
+ eend ${retval} "Failed to down IPX"
+}
diff --git a/net-misc/ipx-utils/ipx-utils-1.1-r3.ebuild b/net-misc/ipx-utils/ipx-utils-1.1-r3.ebuild
new file mode 100644
index 000000000000..5ed3c8e796a6
--- /dev/null
+++ b/net-misc/ipx-utils/ipx-utils-1.1-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils
+
+DESCRIPTION="The IPX Utilities"
+HOMEPAGE="ftp://sunsite.unc.edu/pub/Linux/system/filesystems/ncpfs/"
+SRC_URI="ftp://sunsite.unc.edu/pub/Linux/system/filesystems/ncpfs/${P/-utils}.tar.gz"
+
+LICENSE="ipx-utils GPL-2" # GPL-2 only for init script
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${P/-utils}
+
+src_prepare() {
+ sed -i "s:-O2 -Wall:${CFLAGS}:" "${S}"/Makefile
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-proc.patch #67642
+}
+
+src_install() {
+ dodir /sbin /usr/share/man/man8
+ dodoc "${S}"/README
+ emake DESTDIR="${D}" install
+
+ newconfd "${FILESDIR}"/ipx.confd ipx
+ newinitd "${FILESDIR}"/ipx.init ipx
+}
diff --git a/net-misc/ipx-utils/metadata.xml b/net-misc/ipx-utils/metadata.xml
new file mode 100644
index 000000000000..2e90b802bc7c
--- /dev/null
+++ b/net-misc/ipx-utils/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
+