summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/dante/files/dante-1.1.19-libpam.patch')
-rw-r--r--net-proxy/dante/files/dante-1.1.19-libpam.patch76
1 files changed, 76 insertions, 0 deletions
diff --git a/net-proxy/dante/files/dante-1.1.19-libpam.patch b/net-proxy/dante/files/dante-1.1.19-libpam.patch
new file mode 100644
index 000000000000..5c732e2f1e92
--- /dev/null
+++ b/net-proxy/dante/files/dante-1.1.19-libpam.patch
@@ -0,0 +1,76 @@
+diff -Nru dante-1.1.19.orig/acinclude.m4 dante-1.1.19/acinclude.m4
+--- dante-1.1.19.orig/acinclude.m4 2005-12-18 21:57:57.000000000 +0100
++++ dante-1.1.19/acinclude.m4 2008-06-25 22:24:16.000000000 +0200
+@@ -260,4 +260,4 @@
+
+ tproto($@)])
+
+-# -- acinclude end --
+\ No newline at end of file
++# -- acinclude end --
+diff -Nru dante-1.1.19.orig/configure.ac dante-1.1.19/configure.ac
+--- dante-1.1.19.orig/configure.ac 2006-01-15 16:33:37.000000000 +0100
++++ dante-1.1.19/configure.ac 2008-06-25 22:25:09.000000000 +0200
+@@ -21,7 +21,7 @@
+ #NOTE: save CFLAGS; wish to compile without -O2 when debugging
+ oCFLAGS=$CFLAGS
+ unset CFLAGS
+-AC_AIX #evidently also modifies CFLAGS
++#AC_AIX #evidently also modifies CFLAGS
+ AC_PROG_LIBTOOL
+ autoconf_compflags=$CFLAGS
+ CFLAGS=$oCFLAGS
+@@ -30,18 +30,6 @@
+
+ AM_CONDITIONAL(PRERELEASE, test x$prerelease != x)
+
+-#known keywords for --enable/disable-foo(=yes/no)?
+-LTINTERNAL="dlopen|dlopen_self|dlopen_self_static|fast_install|libtool_lock|win32_dll|shared_with_static_runtimes|shared_with_static_runtimes_CXX|shared_with_static_runtimes_F77"
+-KNOWN_KEYWORDS="$LTINTERNAL|shared|static|debug|warnings|diagnostic|profiling|linting|libwrap|preload|serverdl|clientdl|internal|pidfile"
+-for keyword in `set | egrep '^enable_' | sed -e 's/^enable_\(.*\)=.*/\1/'`;
+-do
+- echo $keyword | egrep "^(${KNOWN_KEYWORDS})$" > /dev/null
+- if test $? -ne 0; then
+- AC_MSG_WARN([unknown option '$keyword', ignoring ...])
+- sleep 10;
+- fi
+-done
+-
+ #Solaris 2.5.1 is broken in many places
+ case $host in
+ *-*-solaris2.5.1)
+@@ -1288,15 +1288,18 @@
+ [ --without-pam disable pam support @<:@default=detect@:>@],
+ [PAM=$withval])
+
++LIBPAM=
+ if test "${PAM}" != no; then
+ #look for PAM header and lib
+ AC_CHECK_HEADERS(security/pam_appl.h, [have_pam_header=t])
+- AC_SEARCH_LIBS(pam_start, pam, [have_libpam=t])
++ AC_CHECK_LIB(pam, pam_start, [have_libpam=t])
+
+ if test x"${have_pam_header}" != x -a x"${have_libpam}" != x; then
+ AC_DEFINE(HAVE_PAM, 1, [PAM support])
++ LIBPAM=-lpam
+ fi
+ fi
++AC_SUBST(LIBPAM)
+
+ #expected select behaviour?
+ unset nb_select_err
+diff -Nru dante-1.1.19.orig/sockd/Makefile.am dante-1.1.19/sockd/Makefile.am
+--- dante-1.1.19.orig/sockd/Makefile.am 2005-11-06 18:37:14.000000000 +0100
++++ dante-1.1.19/sockd/Makefile.am 2008-06-25 22:24:16.000000000 +0200
+@@ -35,9 +35,9 @@
+
+ #XXXhack
+ if STATIC_SOCKD
+-sockd_LDADD = ../libscompat/sockatmark.o ${LIBWRAP}
++sockd_LDADD = ../libscompat/sockatmark.o ${LIBWRAP} ${LIBPAM}
+ else
+-sockd_LDADD = ../libscompat/libscompat.la ${LIBWRAP}
++sockd_LDADD = ../libscompat/libscompat.la ${LIBWRAP} ${LIBPAM}
+ endif
+
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/libscompat