summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/cluster')
-rw-r--r--sci-chemistry/cluster/Manifest1
-rw-r--r--sci-chemistry/cluster/cluster-1.3.081231-r1.ebuild30
-rw-r--r--sci-chemistry/cluster/cluster-1.3.081231.ebuild30
-rw-r--r--sci-chemistry/cluster/files/1.3.081231-includes.patch12
-rw-r--r--sci-chemistry/cluster/files/1.3.081231-ldflags.patch41
-rw-r--r--sci-chemistry/cluster/metadata.xml18
6 files changed, 132 insertions, 0 deletions
diff --git a/sci-chemistry/cluster/Manifest b/sci-chemistry/cluster/Manifest
new file mode 100644
index 000000000000..1a7bcd779934
--- /dev/null
+++ b/sci-chemistry/cluster/Manifest
@@ -0,0 +1 @@
+DIST cluster.1.3.081231.src.tgz 8860 SHA256 4e0986d5ff124936b5fff4b6f8989dd04be11180d6552fddc34b2c10dfcc870f SHA512 af5851ef467458d45ee5f2309c6344ae16145ac371a1b9d0a3d8b5769a18b98877cf7cb65b85f71108d927b0e6c363e06b85a67e7cb2e5e0b41af375cb2db7ac WHIRLPOOL 2f02de20b323792360b28d5a42d233d06be529414e29796a39a439651fee9e8ba73bdd05033907ac7434890bfa2a31aaf57ab98bbe59964d06a2d63646833f5f
diff --git a/sci-chemistry/cluster/cluster-1.3.081231-r1.ebuild b/sci-chemistry/cluster/cluster-1.3.081231-r1.ebuild
new file mode 100644
index 000000000000..801d4209627a
--- /dev/null
+++ b/sci-chemistry/cluster/cluster-1.3.081231-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Build lists of collections of interacting items"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/index.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${PN}.${PV}.src.tgz"
+
+SLOT="0"
+LICENSE="richardson"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${PN}1.3src
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${PV}-includes.patch
+ tc-export CXX
+}
+
+src_install() {
+ newbin ${PN} molprobity-${PN}
+ dodoc README.cluster
+}
diff --git a/sci-chemistry/cluster/cluster-1.3.081231.ebuild b/sci-chemistry/cluster/cluster-1.3.081231.ebuild
new file mode 100644
index 000000000000..abb875d7f2d0
--- /dev/null
+++ b/sci-chemistry/cluster/cluster-1.3.081231.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Build lists of collections of interacting items"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/index.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${PN}.${PV}.src.tgz"
+
+SLOT="0"
+LICENSE="richardson"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${PN}1.3src
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${PV}-includes.patch
+ tc-export CXX
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README.cluster
+}
diff --git a/sci-chemistry/cluster/files/1.3.081231-includes.patch b/sci-chemistry/cluster/files/1.3.081231-includes.patch
new file mode 100644
index 000000000000..a5586a540a4f
--- /dev/null
+++ b/sci-chemistry/cluster/files/1.3.081231-includes.patch
@@ -0,0 +1,12 @@
+diff --git a/cluster.cpp b/cluster.cpp
+index 0a8c3c1..1384949 100644
+--- a/cluster.cpp
++++ b/cluster.cpp
+@@ -24,6 +24,7 @@
+ #include <iostream>
+ #include <vector>
+ #include <string>
++#include <cstring>
+
+ #include <iostream>
+ #include <fstream>
diff --git a/sci-chemistry/cluster/files/1.3.081231-ldflags.patch b/sci-chemistry/cluster/files/1.3.081231-ldflags.patch
new file mode 100644
index 000000000000..1b99f6d662f2
--- /dev/null
+++ b/sci-chemistry/cluster/files/1.3.081231-ldflags.patch
@@ -0,0 +1,41 @@
+ Makefile | 12 ++++++------
+ 1 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 7892054..929564b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,27 +3,27 @@ PROG_FLGS = -D BOOLPREDEFINED
+
+ SRCS = cluster.cpp DisjointSets.cpp utility.cpp
+
+-CFLAGS = $(OPT) $(DEBUG) $(PROG_FLGS)
++CXXFLAGS += $(OPT) $(DEBUG) $(PROG_FLGS)
+
+ LFLAGS =
+
+ OBJLIST = cluster.o DisjointSets.o utility.o
+
+-CXX = g++
++CXX ?= g++
+
+ .cpp.o:
+- $(CXX) -c $*.cpp $(CFLAGS)
++ $(CXX) $(CXXFLAGS) -c $*.cpp
+
+-OPT = -O3
++OPT =
+ DEBUG = $(CXXDEBUGFLAGS)
+
+ all: cluster
+
+ cluster: $(OBJLIST)
+- $(CXX) -o $@ $(OBJLIST) $(LFLAGS)
++ $(CXX) $(LDFLAGS) -o $@ $(OBJLIST)
+
+ depend:
+- makedepend -- $(CFLAGS) -- $(SRCS)
++ makedepend -- $(CXXFLAGS) -- $(SRCS)
+
+ clean:
+ @rm -rf *.o *.ckp ii_files
diff --git a/sci-chemistry/cluster/metadata.xml b/sci-chemistry/cluster/metadata.xml
new file mode 100644
index 000000000000..76f6a5d9e463
--- /dev/null
+++ b/sci-chemistry/cluster/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Cluster is a simple UNIX C++ program to build lists of collections
+of interacting items from records containing interacting pairs
+and larger fragments.
+
+It reads in lines consisting of two or more names and output
+connected clusters of names. Each line of output is
+prefixed with a cluster number, the size of the cluster
+and an optional name string.
+</longdescription>
+</pkgmetadata>