summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild')
-rw-r--r--sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild b/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild
deleted file mode 100644
index 44d186a798cc..000000000000
--- a/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-MY_P="${PN}-v${PV}-prod-src"
-
-DESCRIPTION="Provides an object-oriented application interface to information in mmCIF format"
-HOMEPAGE="http://sw-tools.pdb.org/apps/CIFPARSE-OBJ/index.html"
-SRC_URI="http://sw-tools.pdb.org/apps/CIFPARSE-OBJ/source/${MY_P}.tar.gz"
-
-LICENSE="PDB"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE=""
-
-RDEPEND=""
-DEPEND="
- sys-devel/bison
- sys-devel/flex"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-makefile.patch \
- "${FILESDIR}"/${P}-gcc4.3.patch \
- "${FILESDIR}"/${P}-gcc4.7.patch \
- "${FILESDIR}"/${P}-gcc5_6.patch \
- "${FILESDIR}"/${PN}-7.025-strncasecmp-declaration.patch
-
- sed \
- -e "s:^\(CC=\).*:\1$(tc-getCC):g" \
- -e "s:^\(CCC=\).*:\1$(tc-getCXX):g" \
- -e "s:^\(F77=\).*:\1${FORTRANC}:g" \
- -e "s:^\(F77_LINKER=\).*:\1${FORTRANC}:g" \
- -e "s:-static::g" \
- -i "${S}"/etc/make.* || die "Failed to fix makefile"
-}
-
-src_compile() {
- # parallel make fails
- emake -j1
-}
-
-src_install() {
- dolib.a lib/*
- insinto /usr/include/${PN}
- doins include/*
-}