summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/daemonize/daemonize-1.7.4.ebuild')
-rw-r--r--sys-apps/daemonize/daemonize-1.7.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/daemonize/daemonize-1.7.4.ebuild b/sys-apps/daemonize/daemonize-1.7.4.ebuild
new file mode 100644
index 000000000000..f4968a9cb19d
--- /dev/null
+++ b/sys-apps/daemonize/daemonize-1.7.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Runs a command as a Unix daemon"
+HOMEPAGE="http://bmc.github.com/daemonize/"
+SRC_URI="http://github.com/bmc/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DOCS=( README.md CHANGELOG.md )
+
+src_unpack() {
+ unpack ${A}
+ # Workaround commit suffix from github.
+ mv "${WORKDIR}"/bmc-${PN}-* "${S}" || die
+}
+
+src_prepare() {
+ sed -i \
+ -e 's:\($(CC)\) $(CFLAGS) \(.*\.o\):\1 $(LDFLAGS) \2:' \
+ Makefile.in || die
+}