summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dstat/dstat-0.7.3.ebuild')
-rw-r--r--sys-apps/dstat/dstat-0.7.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/dstat/dstat-0.7.3.ebuild b/sys-apps/dstat/dstat-0.7.3.ebuild
new file mode 100644
index 000000000000..48d9b66cd9a7
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.7.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="wifi doc examples"
+
+RDEPEND="wifi? ( net-wireless/python-wifi )"
+DEPEND=""
+
+src_install() {
+ default
+ if use examples; then
+ dodoc examples/{mstat,read}.py
+ fi
+ if use doc; then
+ dodoc docs/*.html
+ fi
+}