summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/turbotail/turbotail-0.3.ebuild')
-rw-r--r--sys-apps/turbotail/turbotail-0.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/turbotail/turbotail-0.3.ebuild b/sys-apps/turbotail/turbotail-0.3.ebuild
new file mode 100644
index 000000000000..0e651c23f5d9
--- /dev/null
+++ b/sys-apps/turbotail/turbotail-0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="drop-in replacement for 'tail' which uses the kernel DNOTIFY-api"
+HOMEPAGE="http://www.vanheusden.com/turbotail/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 hppa ~ppc ~sparc ~x86"
+IUSE="fam"
+
+DEPEND="fam? ( virtual/fam )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf
+ if use fam; then
+ myconf="-DUSE_FAM -lfam"
+ else
+ myconf="-DUSE_DNOTIFY"
+ fi
+
+ echo "$(tc-getCC) ${myconf} -DVERSION=\"${PV}\" ${PN}.c -o ${PN}"
+ $(tc-getCC) ${myconf} -DVERSION=\"${PV}\" ${PN}.c -o ${PN} \
+ || die "compile failed"
+}
+
+src_install() {
+ dobin turbotail || die "install failed"
+ dodoc readme.txt
+}