summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/refind/refind-0.13.3.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-boot/refind/refind-0.13.3.1.ebuild b/sys-boot/refind/refind-0.13.3.1.ebuild
index 73f27787890e..327f17b7022b 100644
--- a/sys-boot/refind/refind-0.13.3.1.ebuild
+++ b/sys-boot/refind/refind-0.13.3.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit toolchain-funcs secureboot
DESCRIPTION="The UEFI Boot Manager by Rod Smith"
HOMEPAGE="https://www.rodsbooks.com/refind/"
@@ -39,6 +39,7 @@ pkg_setup() {
export EFIARCH=x64
export BUILDARCH=x86_64
fi
+ secureboot_pkg_setup
}
src_prepare() {
@@ -111,6 +112,8 @@ src_install() {
dosbin "mkrlconf"
dosbin "mvrefind"
dosbin "refind-mkdefault"
+
+ secureboot_auto_sign --in-place
}
pkg_postinst() {