summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang-runtime/clang-runtime-9999.ebuild')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-9999.ebuild b/sys-devel/clang-runtime/clang-runtime-9999.ebuild
index 5586ba0ef77f..dcd22734f007 100644
--- a/sys-devel/clang-runtime/clang-runtime-9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-9999.ebuild
@@ -13,13 +13,19 @@ LICENSE="metapackage"
# Note: keep it matching clang-9999 version
SLOT="7.0.0"
KEYWORDS=""
-IUSE="+compiler-rt libcxx openmp +sanitize"
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
RDEPEND="
compiler-rt? (
~sys-libs/compiler-rt-${PV}:${SLOT}
sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
)
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"