summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/e4rat/files')
-rw-r--r--sys-fs/e4rat/files/e4rat-0.2.2-libdir.patch14
-rw-r--r--sys-fs/e4rat/files/e4rat-0.2.2-shared-build.patch74
-rw-r--r--sys-fs/e4rat/files/e4rat-0.2.4-gcc6.patch11
-rw-r--r--sys-fs/e4rat/files/e4rat-0.2.4-strdup.patch41
-rw-r--r--sys-fs/e4rat/files/e4rat-0.2.4-sysmacros.patch13
5 files changed, 0 insertions, 153 deletions
diff --git a/sys-fs/e4rat/files/e4rat-0.2.2-libdir.patch b/sys-fs/e4rat/files/e4rat-0.2.2-libdir.patch
deleted file mode 100644
index eaa2695d7872..000000000000
--- a/sys-fs/e4rat/files/e4rat-0.2.2-libdir.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: e4rat-0.2.2/src/CMakeLists.txt
-===================================================================
---- e4rat-0.2.2.orig/src/CMakeLists.txt
-+++ e4rat-0.2.2/src/CMakeLists.txt
-@@ -170,8 +170,7 @@ endif(NOT BUILD_CORE_LIBRARY_STATIC)
-
- INSTALL(TARGETS ${${PROJECT_NAME}_TARGETS}
- RUNTIME DESTINATION "sbin"
-- LIBRARY DESTINATION "lib"
-- ARCHIVE DESTINATION "lib"
-+ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}"
- )
-
- INSTALL(DIRECTORY DESTINATION "/var/lib/${PROJECT_NAME}")
diff --git a/sys-fs/e4rat/files/e4rat-0.2.2-shared-build.patch b/sys-fs/e4rat/files/e4rat-0.2.2-shared-build.patch
deleted file mode 100644
index 636eb52fb612..000000000000
--- a/sys-fs/e4rat/files/e4rat-0.2.2-shared-build.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-Index: e4rat-0.2.2/CMakeLists.txt
-===================================================================
---- e4rat-0.2.2.orig/CMakeLists.txt
-+++ e4rat-0.2.2/CMakeLists.txt
-@@ -14,7 +14,6 @@ IF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_D
- set(CMAKE_INSTALL_PREFIX "/" CACHE PATH "e4rat install prefix" FORCE)
- ENDIF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
-
--set(Boost_USE_STATIC_LIBS ON)
- set(Boost_USE_MULTITHREADED OFF)
- add_definitions(-DBOOST_FILESYSTEM_VERSION=2)
- find_package(Boost 1.41 COMPONENTS system filesystem regex REQUIRED)
-Index: e4rat-0.2.2/src/CMakeLists.txt
-===================================================================
---- e4rat-0.2.2.orig/src/CMakeLists.txt
-+++ e4rat-0.2.2/src/CMakeLists.txt
-@@ -131,21 +131,12 @@ IF(CMAKE_BUILD_TYPE STREQUAL "debug")
- )
- ENDIF(CMAKE_BUILD_TYPE STREQUAL "debug")
-
--# On 64 bit architecture you cannot link a static to a shared library
--# Therefore -static-libstdc++ will fail.
--if(BUILD_CORE_LIBRARY_STATIC)
-- add_library(${PROJECT_NAME}-core STATIC
-- ${${PROJECT_NAME}-core_SRC}
-- )
--else(BUILD_CORE_LIBRARY_STATIC)
-- add_library(${PROJECT_NAME}-core SHARED
-- ${${PROJECT_NAME}-core_SRC}
-- )
-- set_target_properties(${PROJECT_NAME}-core PROPERTIES
-- SOVERSION 0
-- LINK_FLAGS "-static-libgcc -static-libstdc++"
-- )
--endif(BUILD_CORE_LIBRARY_STATIC)
-+add_library(${PROJECT_NAME}-core SHARED
-+ ${${PROJECT_NAME}-core_SRC}
-+)
-+set_target_properties(${PROJECT_NAME}-core PROPERTIES
-+ SOVERSION 0
-+)
-
- target_link_libraries(${PROJECT_NAME}-core
- ${${PROJECT_NAME}_LIBRARIES}
-@@ -158,15 +149,13 @@ foreach( EXE ${PROJECT_NAME}-collect
- TARGET_LINK_LIBRARIES(${EXE}
- ${PROJECT_NAME}-core
- )
-- set_target_properties(${EXE} PROPERTIES
-- LINK_FLAGS "-static-libgcc -static-libstdc++"
-- )
- endforeach( EXE )
-
- ###
- # install project targets
- ###
- set(${PROJECT_NAME}_TARGETS
-+ ${PROJECT_NAME}-core
- ${PROJECT_NAME}-collect
- ${PROJECT_NAME}-preload
- ${PROJECT_NAME}-realloc
-Index: e4rat-0.2.2/src/cmake/Findaudit.cmake
-===================================================================
---- e4rat-0.2.2.orig/src/cmake/Findaudit.cmake
-+++ e4rat-0.2.2/src/cmake/Findaudit.cmake
-@@ -1,7 +1,7 @@
- FIND_PATH(AUDIT_INCLUDE_DIR libaudit.h /usr/include
- /usr/local/include)
-
--FIND_LIBRARY(AUDIT_LIBRARY NAMES libaudit.a PATH /usr/lib /usr/local/lib)
-+FIND_LIBRARY(AUDIT_LIBRARY NAMES audit PATH /usr/lib /usr/local/lib)
-
- IF (AUDIT_INCLUDE_DIR AND AUDIT_LIBRARY)
- SET(AUDIT_FOUND TRUE)
diff --git a/sys-fs/e4rat/files/e4rat-0.2.4-gcc6.patch b/sys-fs/e4rat/files/e4rat-0.2.4-gcc6.patch
deleted file mode 100644
index cdf14e5c92eb..000000000000
--- a/sys-fs/e4rat/files/e4rat-0.2.4-gcc6.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- e4rat-0.2.4_pre20141201/src/logging.hh.old 2016-09-21 22:01:37.631925077 -0400
-+++ e4rat-0.2.4_pre20141201/src/logging.hh 2016-09-21 22:01:44.351086734 -0400
-@@ -93,7 +93,7 @@
- #define dump_log(...) logger.write(__VA_ARGS__)
-
- #ifdef DEBUG_ENABLED
-- #define debug(format,args...) dump_log(Debug, "%s:%d in %s(): "format, __FILE__, __LINE__, __FUNCTION__, ## args)
-+ #define debug(format,args...) dump_log(Debug, "%s:%d in %s(): " format, __FILE__, __LINE__, __FUNCTION__, ## args)
- #else
- #define debug(format,args...)
- #endif
diff --git a/sys-fs/e4rat/files/e4rat-0.2.4-strdup.patch b/sys-fs/e4rat/files/e4rat-0.2.4-strdup.patch
deleted file mode 100644
index c3a9cd0e8ca0..000000000000
--- a/sys-fs/e4rat/files/e4rat-0.2.4-strdup.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- e4rat-0.2.4_pre20141201/src/e4rat-collect.cc.orig 2014-11-24 12:12:12.000000000 +0300
-+++ e4rat-0.2.4_pre20141201/src/e4rat-collect.cc 2017-02-12 02:16:25.151757182 +0300
-@@ -32,6 +32,7 @@
- #include <fcntl.h>
- #include <fstream>
- #include <signal.h>
-+#include <cstring>
-
- /* EXT2_SUPER_MAGIC */
- #include <ext2fs/ext2_fs.h>
-@@ -361,7 +362,9 @@
- {
- create_pid_late = true;
-
-- outPath = Config::get<std::string>("startup_log_file").c_str();
-+ // It is unsafe to use Config::get<T>(arg)c_str() pointer
-+ // directly, since it may be overwritten by later get calls.
-+ outPath = strdup(Config::get<std::string>("startup_log_file").c_str());
- verbose = 0;
- }
- else
---- e4rat-0.2.4_pre20141201/src/e4rat-preload.cc.orig 2014-11-24 12:12:12.000000000 +0300
-+++ e4rat-0.2.4_pre20141201/src/e4rat-preload.cc 2017-02-12 02:16:38.425552630 +0300
-@@ -25,6 +25,7 @@
-
- #include <iostream>
- #include <fstream>
-+#include <cstring>
-
- #include <sys/types.h>
- #include <sys/stat.h>
-@@ -227,7 +228,8 @@
- try {
- if(getpid() == 1)
- {
-- const char* logfile = Config::get<std::string>("startup_log_file").c_str();
-+ // pointer may change, string must be copied
-+ const char* logfile = strdup(Config::get<std::string>("startup_log_file").c_str());
- notice("Open %s ... ", logfile);
- FILE* infile = fopen(logfile, "r");
- if(!infile)
diff --git a/sys-fs/e4rat/files/e4rat-0.2.4-sysmacros.patch b/sys-fs/e4rat/files/e4rat-0.2.4-sysmacros.patch
deleted file mode 100644
index 5cdcf3f05ae5..000000000000
--- a/sys-fs/e4rat/files/e4rat-0.2.4-sysmacros.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://sourceforge.net/p/e4rat/tickets/5/
-https://bugs.gentoo.org/580534
-
---- a/src/common.hh
-+++ b/src/common.hh
-@@ -20,6 +20,7 @@
- #ifndef COMMON_HH
- #define COMMON_HH
-
-+#include <sys/sysmacros.h>
- #include <linux/types.h>
- #include <boost/filesystem.hpp>
- #include <boost/regex.hpp>