summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/hfsutils/hfsutils-3.2.6_p14.ebuild')
-rw-r--r--sys-fs/hfsutils/hfsutils-3.2.6_p14.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-fs/hfsutils/hfsutils-3.2.6_p14.ebuild b/sys-fs/hfsutils/hfsutils-3.2.6_p14.ebuild
index d6ec2af91798..5df159088c92 100644
--- a/sys-fs/hfsutils/hfsutils-3.2.6_p14.ebuild
+++ b/sys-fs/hfsutils/hfsutils-3.2.6_p14.ebuild
@@ -32,6 +32,7 @@ REQUIRED_USE="tk? ( tcl )"
PATCHES=(
"${FILESDIR}"/largerthan2gb.patch
"${FILESDIR}"/${P/_p*}-fix-tcl-8.6.patch
+ "${FILESDIR}"/${PN}-3.2.6-test-tcl-8.6.patch
)
S=${WORKDIR}/${P/_p*}
@@ -57,6 +58,11 @@ src_compile() {
emake CC="$(tc-getCC)" -C hfsck
}
+src_test() {
+ # Tests reuse the same image name. Let's serialize.
+ emake check -j1
+}
+
src_install() {
dodir /usr/bin /usr/lib /usr/share/man/man1
emake \