summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/wordpress')
-rw-r--r--www-apps/wordpress/Manifest1
-rw-r--r--www-apps/wordpress/wordpress-6.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/www-apps/wordpress/Manifest b/www-apps/wordpress/Manifest
index b7eeaed2b052..2bcd381f92a7 100644
--- a/www-apps/wordpress/Manifest
+++ b/www-apps/wordpress/Manifest
@@ -1,2 +1,3 @@
DIST wordpress-6.1.1.tar.gz 22751086 BLAKE2B fbbee51219e4237236c39255deb9e31e566c630cfc66f0c4744fec249ae1d07473a6222b7ec5d84079e616d8d2e790521e57809d357ab56582b4a292dbad82f1 SHA512 b50dd9b5e1628a0285d3f0121d6b4cb3617fb696907ef06c935b40d0a46c9853ce12200e011a58675830602aa6d5b6470a98e8cefeec0f7464145bdc344780bb
DIST wordpress-6.2-RC3.tar.gz 23018903 BLAKE2B 268299759a2a412f60d33162a54f677acb424100417bca7e207be5d5e5fb9a230f3a9f6db1039f93ea0513fe4be3f5622b46a1f598b56af08bb4185c56e6103d SHA512 925a3456a61655035d0162a5051307336b6e586aca216a45cc17239266c6e6288924ff6610409d20759bf083c36619e77335852b67ab302d9892cacd2d6dec17
+DIST wordpress-6.2.tar.gz 23018887 BLAKE2B 796a0e5c07c8628fbb6406f79b31123f4328f628b8814b02d506f4aed7217ccc5fc07aff3f441be0f1aa55fe8b9a4c184b2b5d0ed0892f1dedddab101632a70d SHA512 207e2d7aad658772f33c91ed37440b06029de7977847efde5ccd6b4687e7430f3f1a6d9e6d40d1b09d0565ed12adc1e25dc4f34a0102aae2899ef9a8ef8b3baf
diff --git a/www-apps/wordpress/wordpress-6.2.ebuild b/www-apps/wordpress/wordpress-6.2.ebuild
new file mode 100644
index 000000000000..b6c209d75a8c
--- /dev/null
+++ b/www-apps/wordpress/wordpress-6.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
+HOMEPAGE="https://wordpress.org/"
+SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="GPL-2+"
+if [[ ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+RDEPEND="virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
+
+need_httpd_cgi
+
+IUSE="+akismet examples +themes vhosts"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc readme.html
+ rm readme.html license.txt || die
+
+ if use !akismet ; then
+ rm -R wp-content/plugins/akismet/ || die
+ fi
+ if use !examples ; then
+ rm wp-content/plugins/hello.php || die
+ fi
+ if use !themes ; then
+ rm -R wp-content/themes/*/ || die
+ fi
+
+ [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/index.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
+ webapp_serverowned "${MY_HTDOCSDIR}"
+ # allows plugins update if allowed within WP
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/includes/file.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/wp-config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}