summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/qutebrowser/files/qutebrowser-2.3.1-pyyaml60.patch19
-rw-r--r--www-client/qutebrowser/qutebrowser-2.3.1-r2.ebuild4
2 files changed, 23 insertions, 0 deletions
diff --git a/www-client/qutebrowser/files/qutebrowser-2.3.1-pyyaml60.patch b/www-client/qutebrowser/files/qutebrowser-2.3.1-pyyaml60.patch
new file mode 100644
index 000000000000..d585109b9f2c
--- /dev/null
+++ b/www-client/qutebrowser/files/qutebrowser-2.3.1-pyyaml60.patch
@@ -0,0 +1,19 @@
+https://github.com/qutebrowser/qutebrowser/commit/1547a48
+From: Florian Bruhin <me@the-compiler.org>
+Date: Thu, 14 Oct 2021 09:05:07 +0200
+Subject: [PATCH] tests: Adjust for PyYAML 6.0
+--- a/tests/unit/utils/test_utils.py
++++ b/tests/unit/utils/test_utils.py
+@@ -809,8 +809,11 @@ def test_load(self):
+ assert utils.yaml_load("[1, 2]") == [1, 2]
+
+ def test_load_float_bug(self):
+- with pytest.raises(yaml.YAMLError):
++ try:
+ utils.yaml_load("._")
++ except yaml.YAMLError:
++ # Either no exception or YAMLError, not ValueError
++ pass
+
+ def test_load_file(self, tmp_path):
+ tmpfile = tmp_path / 'foo.yml'
diff --git a/www-client/qutebrowser/qutebrowser-2.3.1-r2.ebuild b/www-client/qutebrowser/qutebrowser-2.3.1-r2.ebuild
index f196542337c4..3a90e9763a2d 100644
--- a/www-client/qutebrowser/qutebrowser-2.3.1-r2.ebuild
+++ b/www-client/qutebrowser/qutebrowser-2.3.1-r2.ebuild
@@ -58,6 +58,10 @@ BDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/${P}-pyyaml60.patch
+)
+
python_prepare_all() {
distutils-r1_python_prepare_all