summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmpower/wmpower-0.4.3.ebuild')
-rw-r--r--x11-plugins/wmpower/wmpower-0.4.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/wmpower/wmpower-0.4.3.ebuild b/x11-plugins/wmpower/wmpower-0.4.3.ebuild
new file mode 100644
index 000000000000..230a58b31ba6
--- /dev/null
+++ b/x11-plugins/wmpower/wmpower-0.4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="a dockapp to get/set power management status for laptops (APM, ACPI
+and CPUfreq)"
+HOMEPAGE="http://wmpower.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wmpower/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_compile() {
+ # override wmpower self-calculated cflags
+ econf MY_CFLAGS="${CFLAGS}" || die "Configuration failed"
+ emake prefix="/usr/" || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS BUGS ChangeLog LEGGIMI NEWS README README.compal THANKS TODO
+}