summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-fsguard-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-fsguard-plugin/Manifest b/xfce-extra/xfce4-fsguard-plugin/Manifest
index ab6c48b6da82..f967a8e90b31 100644
--- a/xfce-extra/xfce4-fsguard-plugin/Manifest
+++ b/xfce-extra/xfce4-fsguard-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-fsguard-plugin-1.1.0.tar.bz2 360463 BLAKE2B a83bfcf9d2847a2c37731c6549a51d1d6e18a5a8d689e5c6b7bd3270988cccf25007aa6b47bd70937f61998c676e08ab071caf41b50631d031e5c11fb8921932 SHA512 c5e49a045f1987d57c6e6d120ad25785d2f9ad4e97d07af3d40ab88c268b5b8417deba40e0277ecc1725092063fa2a7f94aa163579f04a419aad5b4e47c79d7d
+DIST xfce4-fsguard-plugin-1.1.1.tar.bz2 367902 BLAKE2B 2fbd088cc2a53dc99e01fbbc880c6223bb3cb8f030cfbed5373d50b7a1e37a072f71beed2f2e84b7f0adcbce28cd0d6cc0c32356589195482c9dee143d04e46c SHA512 9b8a8c171baddc0261e4253c2e710c5d2e180e7ee669915f5a81e53778775880623af43b1638679b86d6a3e077826a69a948577a558e768fa41924ce5d1006fe
diff --git a/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.1.ebuild b/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.1.ebuild
new file mode 100644
index 000000000000..efd533fc2098
--- /dev/null
+++ b/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A filesystem guard plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-fsguard-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}