aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorILMostro <ilmostro7@gmail.com>2018-06-19 21:13:25 -0500
committerILMostro <ilmostro7@gmail.com>2018-06-19 21:13:25 -0500
commit16d3a867ccac57576ef5353b89873a32f0fc0f45 (patch)
treea97cb8041ce479dba07417694e4f8ed87161229e
parentadded copy of `x11-wm/awesome` from portage tree to overlay before updating (diff)
downloadag-ops-16d3a867ccac57576ef5353b89873a32f0fc0f45.tar.gz
ag-ops-16d3a867ccac57576ef5353b89873a32f0fc0f45.tar.bz2
ag-ops-16d3a867ccac57576ef5353b89873a32f0fc0f45.zip
patched `dev-lua/lgi` wrt https://github.com/pavouk/lgi/issues/196
-rw-r--r--dev-lua/lgi/files/lgi-0.9.2.patch21
-rw-r--r--dev-lua/lgi/lgi-0.9.2.ebuild7
-rw-r--r--x11-wm/awesome/awesome-4.2-r2.ebuild2
3 files changed, 27 insertions, 3 deletions
diff --git a/dev-lua/lgi/files/lgi-0.9.2.patch b/dev-lua/lgi/files/lgi-0.9.2.patch
new file mode 100644
index 0000000..b6fd231
--- /dev/null
+++ b/dev-lua/lgi/files/lgi-0.9.2.patch
@@ -0,0 +1,21 @@
+diff --git a/lgi/Makefile b/lgi/Makefile
+index 08419bd..a56df02 100644
+--- a/lgi/Makefile
++++ b/lgi/Makefile
+@@ -5,11 +5,12 @@
+ # License: MIT
+ #
+
+-PREFIX = /usr/local
++PREFIX = /usr
+ HOST_OS = $(shell uname -s | tr A-Z a-z)
+-LUA_VERSION=5.1
+-LUA_LIBDIR = $(PREFIX)/lib/lua/$(LUA_VERSION)
+-LUA_SHAREDIR = $(PREFIX)/share/lua/$(LUA_VERSION)
++# Dirty hack for the time being
++# See https://github.com/pavouk/lgi/issues/196
++LUA_LIBDIR = $(PREFIX)/lib/lua
++LUA_SHAREDIR = $(PREFIX)/share/lua
+
+ PKG_CONFIG = pkg-config
+ GINAME = gobject-introspection-1.0
diff --git a/dev-lua/lgi/lgi-0.9.2.ebuild b/dev-lua/lgi/lgi-0.9.2.ebuild
index 2af418f..37a5f2d 100644
--- a/dev-lua/lgi/lgi-0.9.2.ebuild
+++ b/dev-lua/lgi/lgi-0.9.2.ebuild
@@ -5,7 +5,8 @@ EAPI=6
VIRTUALX_REQUIRED="manual"
-inherit eutils toolchain-funcs flag-o-matic virtualx
+# inherit eutils toolchain-funcs flag-o-matic virtualx
+inherit eutils toolchain-funcs virtualx
DESCRIPTION="Lua bindings using gobject-introspection"
HOMEPAGE="https://github.com/pavouk/lgi"
@@ -15,6 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm ppc ppc64 x86 ~x86-fbsd"
IUSE="examples test"
+PATCHES="${FILESDIR}/${P}.patch"
RDEPEND="dev-lang/lua:*
dev-libs/gobject-introspection
@@ -29,7 +31,8 @@ DEPEND="${RDEPEND}
)"
src_prepare() {
- default
+ default_src_prepare
+ eapply_user
}
src_compile() {
diff --git a/x11-wm/awesome/awesome-4.2-r2.ebuild b/x11-wm/awesome/awesome-4.2-r2.ebuild
index 3642f6c..53e60f9 100644
--- a/x11-wm/awesome/awesome-4.2-r2.ebuild
+++ b/x11-wm/awesome/awesome-4.2-r2.ebuild
@@ -15,7 +15,7 @@ KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="dbus doc elibc_FreeBSD gnome luajit test"
RDEPEND="
- >=dev-lang/lua-5.1:0
+ >=dev-lang/lua-5.1:*
luajit? ( dev-lang/luajit:2 )
dev-libs/glib:2
>=dev-libs/libxdg-basedir-1