aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bernardo <samuelbernardo.mail@gmail.com>2020-05-04 03:08:49 +0100
committerSamuel Bernardo <samuelbernardo.mail@gmail.com>2020-05-04 03:08:49 +0100
commitaeec18e53bea54d6a4851b2848d9195e867e207a (patch)
tree8b9c741756122c332ba2548a41ecac5aee964a2f /dev-ruby/tilt
parentUpdate OpenNebula and clean up old versions (diff)
downloadssnb-aeec18e53bea54d6a4851b2848d9195e867e207a.tar.gz
ssnb-aeec18e53bea54d6a4851b2848d9195e867e207a.tar.bz2
ssnb-aeec18e53bea54d6a4851b2848d9195e867e207a.zip
Update ruby gems ebuilds
Signed-off-by: Samuel Bernardo <samuelbernardo.mail@gmail.com>
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/Manifest4
-rw-r--r--dev-ruby/tilt/tilt-2.0.10.ebuild44
-rw-r--r--dev-ruby/tilt/tilt-2.0.6.ebuild6
3 files changed, 50 insertions, 4 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index c66b8d3..4bc8f2c 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1,3 +1,5 @@
+DIST tilt-2.0.10.gem 22528 BLAKE2B c9d9d79fb2aa654baacb9b533b2d7a1139bff65d495b4b33c915c9267ad16f0cde67a25c455160baa7f11d8fbefe704f78fc4fa81cb830ea14075712adb706ec SHA512 d2e0e1976da24ea4d8581d29a3ac2c0772c2e42f1cd04c48f1e3c1745a14d7cd319f14cead3e5341ec0f6c07aa216b50c29ad96984a85a9757ff9f7cc89b80df
DIST tilt-2.0.6.gem 54272 BLAKE2B e6b19915e3080c96a55ae5b21f3514b742b35658b3cd7f83d455d2ec4dfa389f7698ff7983c2f5701491d31e18eed7501e749f11dac59427f4eca10e79308f23 SHA512 173245f5edd8cf2d31edccd36d375530448e58da1fd744bdf471818ee9b306317f52ecfb9aa8c39ec7746ea3900e600ebfc5f96dfa66724d3e8a4386bd9da260
-EBUILD tilt-2.0.6.ebuild 1533 BLAKE2B d985a37bc0ee8b03fea786a684d25307984778e74cd2e2722dfaaec0d466927a4b1e48a92de015489e7efe04e92e633db1bb193191b6fc46db810442ff306d5c SHA512 f67393a811811b4735e80768f3658e6bd2fc78f988b9125cfce0f58262d0873dc3a2312d10f0dc6a4374dcafd8045fbde2ebdcc1b09efdf372ea21d36266dd20
+EBUILD tilt-2.0.10.ebuild 1519 BLAKE2B 82674b0d543ed69bf1d3b46d5ec50bdfe72fd02b592a4dddfd8ae710800a156f36fc80441ee74f675d6ba121d7958a1b6ff4f7d5bf4131862b1dc16acf0190ea SHA512 d4e3172f888ae7711a8566a3ee2b32668c5669d740dcfe4cf83fafa0edeeb8bcb84b9029a7ef2f9caaf2be76f60fc5bd438eade33db1d95d7642877c8840f744
+EBUILD tilt-2.0.6.ebuild 1519 BLAKE2B 82674b0d543ed69bf1d3b46d5ec50bdfe72fd02b592a4dddfd8ae710800a156f36fc80441ee74f675d6ba121d7958a1b6ff4f7d5bf4131862b1dc16acf0190ea SHA512 d4e3172f888ae7711a8566a3ee2b32668c5669d740dcfe4cf83fafa0edeeb8bcb84b9029a7ef2f9caaf2be76f60fc5bd438eade33db1d95d7642877c8840f744
MISC metadata.xml 157 BLAKE2B 1530828eb2b8b2b3a06f508d10f875b551a7c7cea968cc7f462561b8c4589c2a4de195d17ed22cf6f0887c07f7d6d036cdd997c5660498d2abf767a76965e1f6 SHA512 0cec73b966de88015ea4c7212723d848d367608aa93658bb945f298a8000c4ba8aba73c9eb8481859fb5bbed45e80dae32c628caf81e027a4ad8eafa7e632851
diff --git a/dev-ruby/tilt/tilt-2.0.10.ebuild b/dev-ruby/tilt/tilt-2.0.10.ebuild
new file mode 100644
index 0000000..9de0707
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/rtomayko/tilt"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/bluecloth
+ dev-ruby/coffee-script
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+ !!<dev-ruby/maruku-0.7.2 )"
+
+ruby_add_rdepend ">=dev-ruby/builder-2.0.0:*
+ !!<dev-ruby/tilt-1.4.1-r2:0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
+ sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
+ #sed -i -e '/docbook templates/,/^ end/ s:^:#:' test/tilt_asciidoctor_test.rb || die
+}
diff --git a/dev-ruby/tilt/tilt-2.0.6.ebuild b/dev-ruby/tilt/tilt-2.0.6.ebuild
index 6c0c12d..9de0707 100644
--- a/dev-ruby/tilt/tilt-2.0.6.ebuild
+++ b/dev-ruby/tilt/tilt-2.0.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=6
+EAPI=7
-USE_RUBY="ruby20 ruby21 ruby22 ruby23 ruby24 ruby25"
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"