summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/melt/melt-1.0.ebuild')
-rw-r--r--dev-util/melt/melt-1.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/melt/melt-1.0.ebuild b/dev-util/melt/melt-1.0.ebuild
new file mode 100644
index 0000000..2041a7a
--- /dev/null
+++ b/dev-util/melt/melt-1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils versionator
+
+MY_P="$(replace_version_separator '_' '-' ${P})"
+DESCRIPTION="High-level domain specific language for extending or customizing the Gnu Compiler Collection"
+HOMEPAGE="http://gcc-melt.org/"
+SUFFIX="plugin-for-gcc-4.7-or-4.8"
+SRC_URI="http://gcc-melt.org/${MY_P}-${SUFFIX}.tar.bz2"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+
+DEPEND="
+doc? ( app-text/texi2html )
+>=sys-devel/gcc-4.6
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}-${SUFFIX}"
+
+src_configure() { :; }
+
+src_compile() {
+ # Build cannot be parallel
+ make
+
+ if use doc; then
+ emake melt-gendoc
+ emake doc
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install-melt-includes install-melt-sources install-melt-modules install-melt-mk install-melt-so
+
+ if use doc; then
+ dohtml *.html
+ dodoc *.pdf
+ fi
+} \ No newline at end of file