aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gconf/gconf-3.2.6-r3.ebuild')
-rw-r--r--gnome-base/gconf/gconf-3.2.6-r3.ebuild114
1 files changed, 114 insertions, 0 deletions
diff --git a/gnome-base/gconf/gconf-3.2.6-r3.ebuild b/gnome-base/gconf/gconf-3.2.6-r3.ebuild
new file mode 100644
index 0000000..c832c62
--- /dev/null
+++ b/gnome-base/gconf/gconf-3.2.6-r3.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME_ORG_MODULE="GConf"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="xml"
+
+inherit eutils gnome2-multilib python-r1
+
+DESCRIPTION="GNOME configuration system and daemon"
+HOMEPAGE="http://projects.gnome.org/gconf/"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE="debug +introspection ldap policykit"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.31:2[${MULTILIB_USEDEP}]
+ >=dev-libs/dbus-glib-0.74:=[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1:=[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:=[${MULTILIB_USEDEP}] )
+ ldap? ( net-nds/openldap:=[${MULTILIB_USEDEP}] )
+ policykit? ( sys-auth/polkit:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+ kill_gconf
+}
+
+src_prepare() {
+ # Do not start gconfd when installing schemas, fix bug #238276, upstream #631983
+ epatch "${FILESDIR}/${PN}-2.24.0-no-gconfd.patch"
+
+ # Do not crash in gconf_entry_set_value() when entry pointer is NULL, upstream #631985
+ epatch "${FILESDIR}/${PN}-2.28.0-entry-set-value-sigsegv.patch"
+
+ # From 'master'
+ # mconvert: enable recursive scheme lookup and fix a crasher
+ epatch "${FILESDIR}/${P}-mconvert-crasher.patch"
+
+ # dbus: Don't spew to console when unable to connect to dbus daemon
+ epatch "${FILESDIR}/${P}-spew-console-error.patch"
+
+ # gsettings-data-convert: Warn (and fix) invalid schema paths
+ epatch "${FILESDIR}/${P}-gsettings-data-convert-paths.patch"
+
+ gnome2-multilib_src_prepare
+}
+
+src_configure() {
+ gnome2-multilib_src_configure \
+ --disable-static \
+ --enable-gsettings-backend \
+ --with-gtk=3.0 \
+ --disable-orbit \
+ $(use_enable introspection) \
+ $(use_with ldap openldap) \
+ $(use_enable policykit defaults-service)
+}
+
+src_install() {
+ gnome2-multilib_src_install
+ python_replicate_script "${ED}"/usr/bin/gsettings-schema-convert || die
+
+ keepdir /etc/gconf/gconf.xml.mandatory
+ keepdir /etc/gconf/gconf.xml.defaults
+ # Make sure this directory exists, bug #268070, upstream #572027
+ keepdir /etc/gconf/gconf.xml.system
+
+ echo "CONFIG_PROTECT_MASK=\"/etc/gconf\"" > 50gconf
+ echo 'GSETTINGS_BACKEND="gconf"' >> 50gconf
+ doenvd 50gconf
+ dodir /root/.gconfd
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ # change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find "${EPREFIX}"/etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+
+ einfo "changing permissions for gconf files"
+ find "${EPREFIX}"/etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+}
+
+kill_gconf() {
+ # This function will kill all running gconfd-2 that could be causing troubles
+ if [ -x "${EPREFIX}"/usr/bin/gconftool-2 ]
+ then
+ "${EPREFIX}"/usr/bin/gconftool-2 --shutdown
+ fi
+
+ return 0
+}