aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.2.3-r1.ebuild')
-rw-r--r--media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.2.3-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.2.3-r1.ebuild b/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.2.3-r1.ebuild
new file mode 100644
index 0000000..b41f001
--- /dev/null
+++ b/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.2.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit gst-plugins-good-multilib
+
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libSM[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ x11-proto/damageproto[${MULTILIB_USEDEP}]
+ x11-proto/fixesproto[${MULTILIB_USEDEP}]
+ x11-proto/xextproto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+"
+
+# xshm is a compile time option of ximage
+GST_PLUGINS_BUILD="x xshm"
+GST_PLUGINS_BUILD_DIR="ximage"