summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2015-03-09 13:02:24 +0100
committerhaarp <main.haarp@gmail.com>2015-03-09 13:02:24 +0100
commit668b5c8d011a2e77f521dada397d17e2084124bd (patch)
treec7bc559e7e51257ba6cc231bb775ab646a5b1b3f /x11-misc
downloadhaarp-668b5c8d011a2e77f521dada397d17e2084124bd.tar.gz
haarp-668b5c8d011a2e77f521dada397d17e2084124bd.tar.bz2
haarp-668b5c8d011a2e77f521dada397d17e2084124bd.zip
populate overlay
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/XCreateMouseVoid/Manifest2
-rw-r--r--x11-misc/XCreateMouseVoid/XCreateMouseVoid-9999.ebuild36
-rw-r--r--x11-misc/switchscreen/Manifest2
-rw-r--r--x11-misc/switchscreen/switchscreen-0.1.1.ebuild27
-rw-r--r--x11-misc/xiccd/Manifest2
-rw-r--r--x11-misc/xiccd/xiccd-0.2.2.ebuild24
6 files changed, 93 insertions, 0 deletions
diff --git a/x11-misc/XCreateMouseVoid/Manifest b/x11-misc/XCreateMouseVoid/Manifest
new file mode 100644
index 0000000..eb22e6e
--- /dev/null
+++ b/x11-misc/XCreateMouseVoid/Manifest
@@ -0,0 +1,2 @@
+DIST XCreateMouseVoid-9999.zip 5109 SHA256 a4c1641b4c4fd093a5003c6068884b1dcbab4ef55ce69e9cb00c61e81f014c4f SHA512 af16569b6f808471e613a42453e27970b126b396f52a409458a25416f440ae3a0a507cd146708114a7675d3ce3a6cb81440992d6b68b2558fbed4392837e8f03 WHIRLPOOL ccbc91f93e956d84256fbc635462c3d09aee6e1b0e6e9fc2d2ef3f9d342f6d900c4abf2615d5e39eca30f1934cf4320d6021b522117d39e05ac6e457dfdd1cbf
+EBUILD XCreateMouseVoid-9999.ebuild 693 SHA256 4a1577d2c663863bbcd6eff54ca997c9a9b34c3f3c87f5fd0aa22e7213071ba7 SHA512 f109556e3b7ad303d979858270bd46d4cfc08992a2673acd6d42b291da3ac536ae0f81a2cdb8ef5a0236469b55cd0184f8072a8a3f2cbd7d8a52630c7e16848e WHIRLPOOL a7f12ff5127037a01f09040f7df368ec80a9d2f7e6bf756664a48c132cf68ec7b1da44beaa80986e9fbedae22c8adba8c246a76963ffcb9186f0365885daad6a
diff --git a/x11-misc/XCreateMouseVoid/XCreateMouseVoid-9999.ebuild b/x11-misc/XCreateMouseVoid/XCreateMouseVoid-9999.ebuild
new file mode 100644
index 0000000..2ce4d7f
--- /dev/null
+++ b/x11-misc/XCreateMouseVoid/XCreateMouseVoid-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Creates an undecorated black window and prevents the mouse from entering that window"
+HOMEPAGE="https://github.com/cas--/XCreateMouseVoid"
+SRC_URI="https://github.com/cas--/XCreateMouseVoid/archive/master.zip -> ${P}.zip"
+
+LICENSE="none"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="x11-base/xorg-server"
+DEPEND=${RDEPEND}
+
+S="${WORKDIR}/${PN}-master"
+
+src_prepare() {
+ sed -i -e 's/gcc/${CC}/g' Makefile
+}
+
+src_compile() {
+ if use debug; then
+ emake debug
+ else
+ emake
+ fi
+}
+
+src_install() {
+ dobin XCreateMouseVoid
+ dodoc README.mdown
+}
diff --git a/x11-misc/switchscreen/Manifest b/x11-misc/switchscreen/Manifest
new file mode 100644
index 0000000..ce93e88
--- /dev/null
+++ b/x11-misc/switchscreen/Manifest
@@ -0,0 +1,2 @@
+DIST switchscreen-0.1.1.tar.gz 10214 SHA256 122575b0a35e9af26412340547f7912f5460138dd4367b35e86bf681f22a2fe6 SHA512 583f2cbf87878ef55fd31fb2270ac84b546c04c0d7adae874cab9647684b76a1ff52fb9b686222d9ac338c78b28fa147ce66d81007fc9091680b2cc702cbbb80 WHIRLPOOL 07b3566a48dca54e1459c4e32771f584fc7901d0fa4996ad1f9a5dc54eec6b08932875de2321a7916e91cfc4167ba3d845ee8b1eac0977eadb4adb567669eabd
+EBUILD switchscreen-0.1.1.ebuild 610 SHA256 e67f3c02861cf10ff17e4569378bd022c880ef9c297a1c4353c63b14736c00c9 SHA512 fed25fcb165b8cacf6044ff45bbae1510651c04c38181b84a40a7e38b63da19eb3f5ce7e08dbbdf573d7cb7ea2ad7797cf06da1e53bfcfd88eac7555e50a9ebc WHIRLPOOL 3f073b471de761ddf3922aa025165b48e4da577a8633ee78a9dfcd4e4585398141b4c4b3812b2d73f05976d768dd8cbdb9293afc05fe7cb9f9348530b4562f0c
diff --git a/x11-misc/switchscreen/switchscreen-0.1.1.ebuild b/x11-misc/switchscreen/switchscreen-0.1.1.ebuild
new file mode 100644
index 0000000..9505b94
--- /dev/null
+++ b/x11-misc/switchscreen/switchscreen-0.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Move the X mouse cursor to a given point on a given screen"
+HOMEPAGE="http://sampo.kapsi.fi/switchscreen/"
+SRC_URI="http://sampo.kapsi.fi/switchscreen/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-base/xorg-server"
+DEPEND=${RDEPEND}
+
+src_prepare() {
+ sed -i -e '/CC=/d' -e '/CFLAGS=/d' -e '/LDFLAGS=/d' Makefile
+ sed -i -e 's/gcc/${CC} ${CFLAGS}/g' Makefile
+}
+
+src_install() {
+ dobin switchscreen togglescreen.sh
+ dodoc README
+}
diff --git a/x11-misc/xiccd/Manifest b/x11-misc/xiccd/Manifest
new file mode 100644
index 0000000..7db2403
--- /dev/null
+++ b/x11-misc/xiccd/Manifest
@@ -0,0 +1,2 @@
+DIST xiccd-0.2.2.tar.gz 30599 SHA256 a5b142d7ecb591492fc8d61ccecf3b9eda56aef35c69cfa3ed766daf705cee92 SHA512 0e6b2ce9fa7c656e8d045f18b0afc58cc289d35de926db3b35ebb6ef4170fc6aed924a6e366c3fbd29e7fc247e4845eedc785c9f9137639312b29748893cccec WHIRLPOOL e97f0cf610280ca9f2d8556127877d9ff669f96845850bc3bd55671f1f0a08bb73f944bdc44a6b0c167d041ffc4990321637907e6005b6b7bd3903d2f9782a58
+EBUILD xiccd-0.2.2.ebuild 536 SHA256 b7768c9babf91d82a268aced92a50d69962d83d7717ae9f97367f31677eb6c04 SHA512 ed55cf175dcd4ac2ea7e4e1540263dfaca55316adc1694e5c9b698c12ef8ce276fc184aa42fb61a9cc0cba32e16a938b9a0a12ebd6fb617f4dc5df015333a958 WHIRLPOOL b670648285d7160ebd222871293d5a684f08c6da13e6e31ea8404edee85863f4a8e13a13f340b8871393498db8983bf7fd4dae0add944430c7da53c1b842dfa0
diff --git a/x11-misc/xiccd/xiccd-0.2.2.ebuild b/x11-misc/xiccd/xiccd-0.2.2.ebuild
new file mode 100644
index 0000000..b40c77a
--- /dev/null
+++ b/x11-misc/xiccd/xiccd-0.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit autotools
+
+DESCRIPTION="xiccd is a simple bridge between colord and X"
+HOMEPAGE="https://github.com/agalakhov/xiccd/"
+SRC_URI="https://github.com/agalakhov/xiccd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.36
+ >=x11-apps/xrandr-1.3
+ >=x11-misc/colord-1.0.2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+}