summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2019-09-04 22:13:22 +0200
committerhaarp <main.haarp@gmail.com>2019-09-04 22:13:22 +0200
commite979a61c6f23de478d55deca9897ebe09dffbf75 (patch)
tree1caae5d832725fabb061c92ef46b560c928c6444 /x11-misc
parentPrusaSlicer 2.1.0-rc (diff)
downloadhaarp-e979a61c6f23de478d55deca9897ebe09dffbf75.tar.gz
haarp-e979a61c6f23de478d55deca9897ebe09dffbf75.tar.bz2
haarp-e979a61c6f23de478d55deca9897ebe09dffbf75.zip
Bring back the classic, alltray
Signed-off-by: haarp <main.haarp@gmail.com>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/alltray/Manifest2
-rw-r--r--x11-misc/alltray/alltray-0.7.5.1.ebuild50
-rw-r--r--x11-misc/alltray/files/clarify_glib_gtk_ambiguity.patch63
3 files changed, 115 insertions, 0 deletions
diff --git a/x11-misc/alltray/Manifest b/x11-misc/alltray/Manifest
new file mode 100644
index 0000000..5fb4f0a
--- /dev/null
+++ b/x11-misc/alltray/Manifest
@@ -0,0 +1,2 @@
+AUX clarify_glib_gtk_ambiguity.patch 2533 BLAKE2B 371c05ec1be9b9a377fdb766eacdf98c9b8f1f75b75264b8b9da118f91ae1a288b036216cfb6f7cf3a556a12f1f548fe2a02de0d194d8f09a81728af904ab038 SHA512 784d2c7478dea14e7394622afc621450d22968195a9473f1a0d3e4122ae5a701dcd51429d8a1c74596f9c35dcb6331db4a0c2956295f9573e4348f581b7b3fa7
+EBUILD alltray-0.7.5.1.ebuild 1148 BLAKE2B 079a4dac6a7a87b52552921fce8d09cde514b6caa5096ae02dd57b83b6d71c6be546f7a87d616af294ce58e37e8c26c89f96475238a296da96131349741564e3 SHA512 b998b27227e5845eadbf6455975dd037b63ae9163143fc4e36daa312bd841cd38a4a71dc553ae6654713d562d5bd8a98a2bcf50acc9b0e36c6f6404ed00d42ae
diff --git a/x11-misc/alltray/alltray-0.7.5.1.ebuild b/x11-misc/alltray/alltray-0.7.5.1.ebuild
new file mode 100644
index 0000000..af0da0a
--- /dev/null
+++ b/x11-misc/alltray/alltray-0.7.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+VALA_MIN_API_VERSION="0.14"
+
+inherit autotools git-r3 vala
+
+DESCRIPTION="An application which allows any application to be docked into the system notification area"
+HOMEPAGE="http://alltray.trausch.us/"
+##SRC_URI="https://github.com/mbt/alltray/archive/v${PV}dev.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/mbt/alltray.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ gnome-base/libgtop:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libwnck:1"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ virtual/pkgconfig"
+
+##S=${WORKDIR}/${P}dev
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+src_prepare() {
+ sed -i -e 's:-DG.*DISABLE_DEPRECATED::' src/Makefile.am || die #391101
+
+ sed -i \
+ -e '/Encoding/d' \
+ -e '/Categories/s:Application;::' \
+ -e '/Icon/s:.png::' \
+ data/alltray.desktop.in || die
+
+ vala_src_prepare
+ sed -i -e '/AC_PATH_PROG/s:valac:${VALAC}:g' configure.ac || die
+
+ epatch "$FILESDIR/clarify_glib_gtk_ambiguity.patch"
+
+ eautoreconf
+}
+
diff --git a/x11-misc/alltray/files/clarify_glib_gtk_ambiguity.patch b/x11-misc/alltray/files/clarify_glib_gtk_ambiguity.patch
new file mode 100644
index 0000000..b5b0e76
--- /dev/null
+++ b/x11-misc/alltray/files/clarify_glib_gtk_ambiguity.patch
@@ -0,0 +1,63 @@
+https://github.com/mbt/alltray/pull/7
+
+diff --git a/src/GtkStatusIcon.vala b/src/GtkStatusIcon.vala
+index 325d79a..f70c0cd 100644
+--- a/src/GtkStatusIcon.vala
++++ b/src/GtkStatusIcon.vala
+@@ -40,15 +40,15 @@ namespace AllTray {
+ }
+
+ private void on_popup_menu(uint button, uint activate_time) {
+- Menu pm = new Gtk.Menu();
++ Gtk.Menu pm = new Gtk.Menu();
+
+- MenuItem miToggle = new MenuItem.with_label(_("Toggle Visibility"));
+- MenuItem miSep0 = new SeparatorMenuItem();
+- MenuItem miShowAll = new MenuItem.with_label(_("Force Show All"));
+- MenuItem miHideAll = new MenuItem.with_label(_("Force Hide All"));
+- MenuItem miUndock = new MenuItem.with_label(_("Undock"));
+- MenuItem miSep1 = new SeparatorMenuItem();
+- MenuItem miAbout = new MenuItem.with_label(_("About AllTray..."));
++ Gtk.MenuItem miToggle = new Gtk.MenuItem.with_label(_("Toggle Visibility"));
++ Gtk.MenuItem miSep0 = new SeparatorMenuItem();
++ Gtk.MenuItem miShowAll = new Gtk.MenuItem.with_label(_("Force Show All"));
++ Gtk.MenuItem miHideAll = new Gtk.MenuItem.with_label(_("Force Hide All"));
++ Gtk.MenuItem miUndock = new Gtk.MenuItem.with_label(_("Undock"));
++ Gtk.MenuItem miSep1 = new SeparatorMenuItem();
++ Gtk.MenuItem miAbout = new Gtk.MenuItem.with_label(_("About AllTray..."));
+
+ miToggle.set_submenu(create_window_list());
+
+@@ -67,20 +67,20 @@ namespace AllTray {
+ pm.popup(null, null, null, button, activate_time);
+ }
+
+- private Menu create_window_list() {
+- Menu ret = new Menu();
+- MenuItem miAllWindows = new MenuItem.with_label(_("All Windows"));
++ private Gtk.Menu create_window_list() {
++ Gtk.Menu ret = new Gtk.Menu();
++ Gtk.MenuItem miAllWindows = new Gtk.MenuItem.with_label(_("All Windows"));
+ miAllWindows.activate.connect(() => {
+ toggle_app_visibility();
+ });
+- MenuItem miSep0 = new SeparatorMenuItem();
++ Gtk.MenuItem miSep0 = new SeparatorMenuItem();
+
+ ret.append(miAllWindows); miAllWindows.show();
+ ret.append(miSep0); miSep0.show();
+
+ unowned List<Wnck.Window> ws = this._app.wnck_app.get_windows();
+ foreach(Wnck.Window w in ws) {
+- MenuItem miW = new MenuItem.with_label(w.get_name());
++ Gtk.MenuItem miW = new Gtk.MenuItem.with_label(w.get_name());
+ miW.set_data("target_window", w);
+ miW.activate.connect((miW) => {
+ Wnck.Window mw =
+@@ -94,4 +94,4 @@ namespace AllTray {
+ return(ret);
+ }
+ }
+-}
+\ No newline at end of file
++}