summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/xed/Manifest4
-rw-r--r--app-editors/xed/xed-2.0.2.ebuild (renamed from app-editors/xed/xed-1.6.3.ebuild)34
2 files changed, 22 insertions, 16 deletions
diff --git a/app-editors/xed/Manifest b/app-editors/xed/Manifest
index 16e7021..e933161 100644
--- a/app-editors/xed/Manifest
+++ b/app-editors/xed/Manifest
@@ -1,4 +1,4 @@
-DIST xed-1.6.3.tar.gz 3980046 BLAKE2B 9d390a4f3c88b47d237d7974cd6e4395f1a33e8da1bb1c5f73842ba0e665ad58f3cbac0987502b88abc8a102910deaebe926dbb7ed243d706c33aac2d41dd94f SHA512 919c26aec38f6f9c378527580327561242940bf2f654e5dd2b6bf5446580c76e6c4953bd27f3e946305e0a4842cc0dc78a34e6e33f6a03406d2143852f13b8f3
DIST xed-1.8.3.tar.gz 3953436 BLAKE2B 8deca12fb709f3a665b111d7b0f4395b575ce159ee5a69360f266f2f3d83a2da1b3da6cda20dd4d6669e93c99d51dd974fd27975d805cdfc9c907cf8598a195b SHA512 e596e9ead6642e3b5c0798375f39a7f3d4c177edb845ad3b1905f4f3cd71a46b939c0e1ac408daf634f9fb31746ba0ec7e61c073630d1bda7d74396de01102a5
-EBUILD xed-1.6.3.ebuild 2054 BLAKE2B 2bf00d7ef7003348b70710f4f7032ce2f1217e91e9d7c2aa1c1683a528b7b26c21c1e827bf7c4002bf56e0ee890089af9469e4936c2873e671417c647aad088c SHA512 dcd6e4543a564fd2be1075bb7c697e618b82df067e0adaab6b4a1362f75ce7e11b4c040312df172f0f216d635b1b3a5655393707e5e5dc50ef31a786f88e9fe9
+DIST xed-2.0.2.tar.gz 3969427 BLAKE2B 815e887254e1c73012507e50a077eda8356d636aac0238e1458bc3d927f27aab296cc6dfb946a2ff495a3f954afbdcef7d7b1fb67b0ceffd44f81fc655c55106 SHA512 e3e5d986421e8034685d89b4fa7e9e34d1997118229c057c278674e79f7ccf2b00ccad0826ca0de6ad54340928a95d46dbf45941e66b91e543ff1a7ba4b1ca9d
EBUILD xed-1.8.3.ebuild 2062 BLAKE2B ea28221b545deabdfd1b9fa635b462679d892d6710f6989df5b0c5977409187fb1f765be424dc6139d21f4f0855b52603c2f50fdf24ba901e5312859f2b1e1c4 SHA512 fd53ba40313050ef2ae2d3511c52b4b87349b3bb04f9d71105b2a4afd35b937580941c2a91a9985583ce8f99d6483897e2f99438b8c96e1f5888db67dd7c8f2c
+EBUILD xed-2.0.2.ebuild 2016 BLAKE2B 62b6c7e1d971b2642c217942a5c07940033d21ae1e129fea53582e19f6e8eb680eb09011244b98dc8c7e607d4514465d0cedef0bb1dc392380b686ef434abe59 SHA512 5ca0841a51963bc58c34d968b36654ec155d498e69038fc4008d473bd679ccffe5c2f8966cad002c0b4b5c485883a669e0f7f51651b17dcec4f71f9fde58e1fd
diff --git a/app-editors/xed/xed-1.6.3.ebuild b/app-editors/xed/xed-2.0.2.ebuild
index c5da5cc..fef7344 100644
--- a/app-editors/xed/xed-1.6.3.ebuild
+++ b/app-editors/xed/xed-2.0.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
GNOME2_LA_PUNT="yes" # plugins are dlopened
PYTHON_COMPAT=( python3_{5,6} )
-inherit autotools eutils gnome2 multilib python-single-r1
+inherit eutils gnome2 meson multilib python-single-r1
DESCRIPTION="X-Apps [Text] Editor (Cross-DE, backward-compatible, GTK3, traditional UI)"
HOMEPAGE="https://github.com/linuxmint/xed"
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/linuxmint/xed/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
-IUSE="+python spell test"
+IUSE="doc +python spell test"
# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
# we need to fix that
REQUIRED_USE="python? ( ^^ ( $(python_gen_useflags '*') ) )"
@@ -32,7 +32,7 @@ COMMON_DEPEND="
gnome-base/gsettings-desktop-schemas
gnome-base/gvfs
- x11-libs/xapps
+ >=x11-libs/xapps-1.2.2
x11-libs/libX11
net-libs/libsoup:2.4
@@ -41,9 +41,9 @@ COMMON_DEPEND="
dev-python/pycairo[${PYTHON_USEDEP}]
>=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
dev-libs/libpeas[${PYTHON_USEDEP}] )
+
spell? (
- >=app-text/enchant-1.2:=
- >=app-text/iso-codes-0.35 )
+ app-text/gspell )
"
RDEPEND="${COMMON_DEPEND}
@@ -68,23 +68,29 @@ pkg_setup() {
}
src_prepare() {
-eautoreconf
gnome2_src_prepare
}
src_configure() {
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ DOCS="AUTHORS HACKING NEWS.GEDIT NEWS.PLUMA README"
+
+ local emesonargs=(
+ -Denable_gvfs_metadata=true
+ $(meson_use doc docs)
+ $(meson_use spell enable_spell)
+ )
+
+ meson_src_configure
+}
- gnome2_src_configure \
- --enable-gvfs-metadata \
- $(use_enable spell)
+src_compile() {
+ meson_src_compile
}
src_test() {
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
- GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+ meson_src_test
}
src_install() {
- gnome2_src_install
+ meson_src_install
}