summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDomen Kožar <domen@dev.si>2010-07-07 23:13:17 +0200
committerDomen Kožar <domen@dev.si>2010-07-07 23:13:17 +0200
commitbb42436d726cd7a6dc85bec13a506cdafc85e3e6 (patch)
tree66e4fb59ea4d2ef61ccaac81a9c3b355ec3896a5
parentadded ~amd64 to arista (diff)
downloadiElectric-bb42436d726cd7a6dc85bec13a506cdafc85e3e6.tar.gz
iElectric-bb42436d726cd7a6dc85bec13a506cdafc85e3e6.tar.bz2
iElectric-bb42436d726cd7a6dc85bec13a506cdafc85e3e6.zip
adding g-pypi2 from trunk
-rw-r--r--dev-python/g-pypi2/ChangeLog73
-rw-r--r--dev-python/g-pypi2/g-pypi2-9999.ebuild33
-rw-r--r--dev-python/g-pypi2/metadata.xml8
3 files changed, 114 insertions, 0 deletions
diff --git a/dev-python/g-pypi2/ChangeLog b/dev-python/g-pypi2/ChangeLog
new file mode 100644
index 0000000..ada463f
--- /dev/null
+++ b/dev-python/g-pypi2/ChangeLog
@@ -0,0 +1,73 @@
+# ChangeLog for dev-python/gpypi2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*g-pypi2-9999 (07 Jul 2010)
+
+ 07 Jul 2010; Domen Kožar <domen@dev.si> +g-pypi2-9999.ebuild,
+ +metadata.xml:
+ Add inital ebuild
+
+*<PACKAGE_NAME>-<PACKAGE_VERSION>-<PACKAGE_RELEASE> (DD MMM YYYY)
+
+ DD MMM YYYY; YOUR_NAME <YOUR_EMAIL> changed_file1, changed_file2 :
+ Initial import. Ebuild submitted by submitter_name <submitter_email>.
+ Note that the "changed_file" listing is optional if you are simply bumping
+ the rev of the ebuild and are only making changes to the .ebuild file
+ itself. Also note that we now have a single unified paragraph rather than
+ having the first line separated from the rest by a newline. Everything
+ should be in one block like this. (note by drobbins, 16 Jul 2002)
+
+ DD MMM YYYY; YOUR_NAME <YOUR_EMAIL> changed_file1, changed_file2: this is
+ an earlier ChangeLog entry.
+
+-- Explanation of ChangeLog format:
+
+ ***************************************************************************
+ THIS IS IMPORTANT: The ChangeLog format is a *chronological* account of all
+ changes made to a set of ebuilds. That means that the most recent ChangeLog
+ entry *always* goes at the top of the file. More explanation below.
+ ***************************************************************************
+
+ ***************************************************************************
+ ANOTHER IMPORTANT NOTE: There are some ChangeLogs that don't follow this
+ format and organize all changes under the "correct" "*" entry. This is not
+ correct. However, rather than making a concerted effort to fix these
+ ChangeLogs, we should spend our energy defining a comprehensive and strict
+ XML-based ChangeLog format which we then migrate to. But for any entries to
+ any ChangeLog that *you* make, please make sure to always add entries to the
+ top of the file like a good boy/girl. Even do this if it's clear that you're
+ adding an entry to a b0rked ChangeLog.
+ ***************************************************************************
+
+ This changelog is targeted to users. This means that the comments should be
+ well explained and written in clean English.
+
+ Every new version or revision of the package should be marked by a '*'
+ separator line as above to indicate where in the chronology it was first
+ added to our CVS tree. Any changes since the last revision, really _any
+ changes at all_ have to be added to the top of the file, underneath the
+ initial copyright and cvs header comments, in exactly the same format as this
+ comment. If you are modifying older ebuilds, simply note them as changed
+ files and add your entry to the top of the ChangeLog. Resist the temptation
+ to "organize" your ChangeLog entries by placing them under the "correct" "*"
+ entries -- this isn't the purpose of the "*" entries.
+
+ This means that you start with header line that has the following format,
+ indented two spaces:
+
+ DD MMM YYYY; your_name <your_email> changed_file1, changed_file2: Your
+ explanation should follow. It should be indented and wrapped at a line width
+ of 80 characters. The changed_files can be omitted if they are obvious; for
+ example, if you are only modifying the .ebuild file and committing a new rev
+ of a package. Any details about what exactly changed in the code should be
+ added as a message when the changes are committed to cvs, not in this file.
+
+-- A word regarding credit:
+
+ Please add credit information ("ebuild submitted by ...", "patch submitted
+ by ...") to the ChangeLog. Do not add this information to the ebuilds
+ themselves.
+
+ And remember: Give credit where credit is due. We're all doing this for
+ free, so the best we can hope (and expect!) to receive is credit.
diff --git a/dev-python/g-pypi2/g-pypi2-9999.ebuild b/dev-python/g-pypi2/g-pypi2-9999.ebuild
new file mode 100644
index 0000000..056c08f
--- /dev/null
+++ b/dev-python/g-pypi2/g-pypi2-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="creates ebuilds for Gentoo Linux from Python Package Index"
+HOMEPAGE="http://docs.fubar.si/gpypi2/"
+SRC_URI="http://bitbucket.org/iElectric/${PN}/get/tip.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test doc"
+
+DEPEND="unittest2
+ jinja2
+ yolk
+ pygments
+ argparse
+ test? nose
+ test? mock
+ test? ScriptTest
+ doc? Sphinx"
+
+# Run-time dependencies. Must be defined to whatever this depends on to run.
+# The below is valid if the same run-time depends are required to compile.
+RDEPEND="${DEPEND}"
+
+DOCS="README LICENSE"
+PTHON_MODNAME="gpypi2"
diff --git a/dev-python/g-pypi2/metadata.xml b/dev-python/g-pypi2/metadata.xml
new file mode 100644
index 0000000..d2c27ad
--- /dev/null
+++ b/dev-python/g-pypi2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>domen@dev.si</email>
+</maintainer>
+</pkgmetadata>