aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-09-07 22:56:32 +0800
committerIan Delaney <idella4@gentoo.org>2015-09-07 22:56:32 +0800
commit5246d11806fc0d36d9d0970bd7f0c14875888018 (patch)
tree169ca9fc9b6573af88d9fd85fd9b1470c4285af4 /kde-misc/Webcamoid
parentradical update (diff)
downloadimprovise-5246d11806fc0d36d9d0970bd7f0c14875888018.tar.gz
improvise-5246d11806fc0d36d9d0970bd7f0c14875888018.tar.bz2
improvise-5246d11806fc0d36d9d0970bd7f0c14875888018.zip
mass purge of old broken files
Package-Manager: portage-2.2.20
Diffstat (limited to 'kde-misc/Webcamoid')
-rw-r--r--kde-misc/Webcamoid/Webcamoid-9999-r1.ebuild82
-rw-r--r--kde-misc/Webcamoid/Webcamoid-9999-r2.ebuild75
-rw-r--r--kde-misc/Webcamoid/Webcamoid-9999-r3.ebuild73
-rw-r--r--kde-misc/Webcamoid/Webcamoid-9999.ebuild73
-rw-r--r--kde-misc/Webcamoid/files/setup.cfg2
-rw-r--r--kde-misc/Webcamoid/files/setup.py24
-rw-r--r--kde-misc/Webcamoid/files/setup2.cfg2
-rw-r--r--kde-misc/Webcamoid/files/tampakrap_note.txt25
-rw-r--r--kde-misc/Webcamoid/metadata.xml8
9 files changed, 0 insertions, 364 deletions
diff --git a/kde-misc/Webcamoid/Webcamoid-9999-r1.ebuild b/kde-misc/Webcamoid/Webcamoid-9999-r1.ebuild
deleted file mode 100644
index e554eff..0000000
--- a/kde-misc/Webcamoid/Webcamoid-9999-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-EGIT_REPO_URI="git://github.com/hipersayanX/Webcamoid"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-inherit git-2 python
-#distutils
-
-DESCRIPTION="A plasmoid used to show and take photos with your webcam"
-HOMEPAGE="http://kde-apps.org/content/show.php/Webcamoid?content=144796"
-LICENSE="GPL-3"
-INSTALLDIR="usr/share/apps/plasma/plasmoids/webcamoid/code"
-
-SLOT="4"
-KEYWORDS=""
-IUSE=""
-
-DEPEND="kde-base/pykde4
- kde-base/kdepimlibs
- kde-base/libkworkspace"
-RDEPEND="${DEPEND} media-video/ffmpeg
- kde-base/plasma-runtime"
-
-src_unpack() {
- git-2_src_unpack
- cd ${S}
- cp "${FILESDIR}"/setup.py "${FILESDIR}"/setup.cfg .
- mv contents webcamoid
- touch webcamoid/code/__init__.py webcamoid/__init__.py
- mv webcamoid/code/v4l2 .
-}
-
-src_prepare() {
- python_copy_sources
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- installation() {
- cd v4l2
- $(PYTHON) setup.py install --prefix="${D}usr"
- insinto usr/$(get_libdir)/python$(python_get_version)/site-packages/v4l2
- doins *.py
- cd ../
- $(PYTHON) setup.py install --install-purelib="${D}${INSTALLDIR}"
- }
- python_execute_function -s installation
-
- dobin webcamoid/code/v4l2tools.py
-
- insinto usr/share/kde4/services
- newins metadata.desktop webcamoid.desktop
-
- insinto ${INSTALLDIR}
- doins webcamoid/code/{config.py,__init__.py,main.py,webcamoidgui.py}
- insinto usr/share/apps/plasma/plasmoids/webcamoid/
- doins webcamoid/__init__.py
-
- insinto usr/share/doc/${P}/v4l2
- doins v4l2/{NEWS,README}
-
- insinto usr/share/doc/${P}
- newins README.markdown README
-}
-
-postrm() {
- python_mod_optimize v4l2
- python_mod_optimize usr/share/apps/plasma/plasmoids/webcamoid
-}
-
-postinst() {
- python_mod_optimize v4l2
- python_mod_optimize usr/share/apps/plasma/plasmoids/webcamoid
-}
diff --git a/kde-misc/Webcamoid/Webcamoid-9999-r2.ebuild b/kde-misc/Webcamoid/Webcamoid-9999-r2.ebuild
deleted file mode 100644
index ab745ea..0000000
--- a/kde-misc/Webcamoid/Webcamoid-9999-r2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-EGIT_REPO_URI="git://github.com/hipersayanX/Webcamoid"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-inherit git-2 distutils
-
-DESCRIPTION="A plasmoid used to show and take photos with your webcam"
-HOMEPAGE="http://kde-apps.org/content/show.php/Webcamoid?content=144796"
-LICENSE="GPL-2"
-INSTALLDIR="usr/share/apps/plasma/plasmoids/webcamoid/contents/code"
-
-SLOT="4"
-KEYWORDS=""
-IUSE=""
-
-DEPEND="kde-base/pykde4
- kde-base/kdepimlibs"
-RDEPEND="${DEPEND} media-video/ffmpeg"
-
-DISTUTILS_SETUP_FILES=("contents/code/v4l2|setup.py")
-PYTHON_MODNAME="v4l2.py"
-
-src_unpack() {
- git-2_src_unpack
- cd ${S}
- cp "${FILESDIR}"/setup.py "${FILESDIR}"/setup.cfg .
- cp "${FILESDIR}"/setup2.cfg contents/code/v4l2/
- touch contents/code/__init__.py
-}
-
-src_prepare() {
- python_copy_sources
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- distutils_src_install
-
- installation() {
- cd contents/code/v4l2
- $(PYTHON) setup.py install --prefix="${D}usr"
- insinto usr/$(get_libdir)/python$(python_get_version)/site-packages/v4l2
- doins *.py
- cd ../../../
- $(PYTHON) setup.py install --install-purelib="${D}${INSTALLDIR}"
- }
- python_execute_function -s installation
-
- dobin contents/code/v4l2tools.py
-
- insinto usr/share/kde4/services
- newins metadata.desktop webcamoid.plasmoid
- doins metadata.desktop
-
- insinto ${INSTALLDIR}
- doins contents/code/{config.py,__init__.py,main.py,webcamoidgui.py}
- insinto usr/share/apps/plasma/plasmoids/webcamoid/contents
- cp -a contents/ui {$ED}usr/share/apps/plasma/plasmoids/webcamoid/contents/
- insinto usr/share/apps/plasma/plasmoids/webcamoid/
- doins metadata.desktop
- newins metadata.desktop webcamoid.plasmoid
-
- dodoc contents/code/v4l2/{NEWS,README}
- insinto usr/share/doc/${P}
- newins README.markdown README
-}
diff --git a/kde-misc/Webcamoid/Webcamoid-9999-r3.ebuild b/kde-misc/Webcamoid/Webcamoid-9999-r3.ebuild
deleted file mode 100644
index 10d090c..0000000
--- a/kde-misc/Webcamoid/Webcamoid-9999-r3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-KDE_SCM="git"
-EGIT_REPO_URI="git://github.com/hipersayanX/Webcamoid"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-inherit git-2 distutils
-
-DESCRIPTION="A plasmoid used to show and take photos with your webcam"
-HOMEPAGE="http://kde-apps.org/content/show.php/Webcamoid?content=144796"
-LICENSE="GPL-2"
-INSTALLDIR="usr/share/apps/plasma/plasmoids/webcamoid/contents/code"
-
-SLOT="4"
-KEYWORDS=""
-IUSE=""
-
-DEPEND="kde-base/pykde4
- kde-base/kdepimlibs"
-RDEPEND="${DEPEND} media-video/ffmpeg"
-
-DISTUTILS_SETUP_FILES=("contents/code/v4l2|setup.py")
-PYTHON_MODNAME="v4l2.py webcamoid"
-
-src_unpack() {
- git-2_src_unpack
- cd ${S}
- cp "${FILESDIR}"/setup.py "${FILESDIR}"/setup.cfg .
- cp "${FILESDIR}"/setup2.cfg contents/code/v4l2/
- touch contents/code/__init__.py
-}
-
-src_prepare() {
- python_copy_sources
-}
-
-src_install() {
- installation() {
- cd contents/code/v4l2
- $(PYTHON) setup.py install --prefix="${D}usr"
- insinto usr/$(get_libdir)/python$(python_get_version)/site-packages/v4l2
- doins *.py
- $(PYTHON) setup.py install --install-purelib="${D}${INSTALLDIR}/v4l2"
- insinto ${INSTALLDIR}/v4l2
- doins *.py
-
- cd ../../../
- $(PYTHON) setup.py install --install-purelib="${D}${INSTALLDIR}"
- }
- python_execute_function -s installation
-
- dobin contents/code/v4l2tools.py
-
- insinto usr/share/kde4/services
- newins metadata.desktop webcamoid.plasmoid
- doins metadata.desktop
-
- insinto ${INSTALLDIR}
- doins contents/code/{config.py,__init__.py,main.py,webcamoidgui.py}
- insinto usr/share/apps/plasma/plasmoids/webcamoid/contents
- insinto usr/share/apps/plasma/plasmoids/webcamoid/
- doins metadata.desktop
- newins metadata.desktop webcamoid.plasmoid
-
- dodoc contents/code/v4l2/{NEWS,README}
- insinto usr/share/doc/${P}
- newins README.markdown README
-}
diff --git a/kde-misc/Webcamoid/Webcamoid-9999.ebuild b/kde-misc/Webcamoid/Webcamoid-9999.ebuild
deleted file mode 100644
index e0aa84f..0000000
--- a/kde-misc/Webcamoid/Webcamoid-9999.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-KDE_SCM="git"
-EGIT_REPO_URI="git://github.com/hipersayanX/Webcamoid"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-inherit git-2 distutils
-
-DESCRIPTION="A plasmoid used to show and take photos with your webcam"
-HOMEPAGE="http://kde-apps.org/content/show.php/Webcamoid?content=144796"
-LICENSE="GPL-2"
-INSTALLDIR="usr/share/apps/plasma/plasmoids/webcamoid/contents/code"
-
-SLOT="4"
-KEYWORDS=""
-IUSE=""
-
-DEPEND="kde-base/pykde4
- kde-base/kdepimlibs"
-RDEPEND="${DEPEND} media-video/ffmpeg"
-
-DISTUTILS_SETUP_FILES=("contents/code/v4l2|setup.py")
-PYTHON_MODNAME="v4l2.py webcamoid"
-
-src_unpack() {
- git-2_src_unpack
- cd ${S}
- cp "${FILESDIR}"/setup.py "${FILESDIR}"/setup.cfg .
- cp "${FILESDIR}"/setup2.cfg contents/code/v4l2/
- touch contents/code/__init__.py
-}
-
-src_prepare() {
- python_copy_sources
-}
-
-src_install() {
- installation() {
- d contents/code/v4l2
- $(PYTHON) setup.py install --prefix="${D}usr"
- insinto usr/$(get_libdir)/python$(python_get_version)/site-packages/v4l2
- doins *.py
- $(PYTHON) setup.py install --install-purelib="${D}${INSTALLDIR}/v4l2"
- insinto ${INSTALLDIR}/v4l2
- doins *.py
-
- cd ../../../
- $(PYTHON) setup.py install --install-purelib="${D}${INSTALLDIR}"
- }
- python_execute_function -s installation
-
- dobin contents/code/v4l2tools.py
-
- insinto usr/share/kde4/services
- newins metadata.desktop webcamoid.plasmoid
- doins metadata.desktop
-
- insinto ${INSTALLDIR}
- doins contents/code/{config.py,__init__.py,main.py,webcamoidgui.py}
- insinto usr/share/apps/plasma/plasmoids/webcamoid/contents
- insinto usr/share/apps/plasma/plasmoids/webcamoid/
- doins metadata.desktop
- newins metadata.desktop webcamoid.plasmoid
-
- dodoc contents/code/v4l2/{NEWS,README}
- insinto usr/share/doc/${P}
- newins README.markdown README
-}
diff --git a/kde-misc/Webcamoid/files/setup.cfg b/kde-misc/Webcamoid/files/setup.cfg
deleted file mode 100644
index a744d10..0000000
--- a/kde-misc/Webcamoid/files/setup.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-[install]
-install-data="usr/share/apps/plasma/plasmoids"
diff --git a/kde-misc/Webcamoid/files/setup.py b/kde-misc/Webcamoid/files/setup.py
deleted file mode 100644
index ef47600..0000000
--- a/kde-misc/Webcamoid/files/setup.py
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/usr/bin/env python2
-
-from distutils.core import setup
-
-setup ( name = "webcamoid",
- version = "9999",
- summary = "A plasmoid used to show and take photos with your webcam",
- author = "Gonzalo Exequiel Pedone",
- author_email = "hipersayan.x.gmail.com",
- url = "http://kde-apps.org/",
- package_dir = {'webcamoid/code': 'webcamoid/code'},
- license = 'GPLv3',
- description = "A plasmoid used to show and take photos with your webcam",
- classifiers = (
- 'Development Status :: 4 - Beta',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: GNU General Public License (GPL-3)',
- 'Operating System :: POSIX :: Linux',
- 'Programming Language :: C',
- 'Programming Language :: Python',
- 'Topic :: Multimedia :: Plasmoid',
- ),
-
-)
diff --git a/kde-misc/Webcamoid/files/setup2.cfg b/kde-misc/Webcamoid/files/setup2.cfg
deleted file mode 100644
index 51ea61c..0000000
--- a/kde-misc/Webcamoid/files/setup2.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-[install]
-install-data="usr/$(get_libdir)/python$(python_get_version)/site-packages/v4l2"
diff --git a/kde-misc/Webcamoid/files/tampakrap_note.txt b/kde-misc/Webcamoid/files/tampakrap_note.txt
deleted file mode 100644
index 6038730..0000000
--- a/kde-misc/Webcamoid/files/tampakrap_note.txt
+++ /dev/null
@@ -1,25 +0,0 @@
-date Mon Mar 5 22:45:25 WST 2012
-included ebuild renamed -9999-r1 for the sake of distinguishing versions.
-Yes you can select versions from the history but I don't even know how to use that yet.
-The changes in this;
-
-I have corrected install details;
- - an __init__.py to webcamoid/
- - correct install of content of webcamoid/ usr/share/apps/plasma/plasmoids/
- - toggle back to eclass python distutils enforces processes in pkg_posinst && pkg_postrm
- - take out the distutils vars
-
-It should now give the correct install pattern I was intending.
-Whether this is the right one is dtill to be determined.
-Seeing no-one knows about plasmoids and thei setup, I am figuring it as I go.
-
--r2 is like a combo of the first version which uses distutils and adds the install of the plasmoid itself
-into usr/share/apps/plasma/plasmoids.
-
--r3 refined a little, removed some un-needed lines. Added installing the v4l2 python folder into its place in
-the source into /usr/share/apps/plasma/plasmoids/webcamoid
-
-Just don't consider this as a suggested final form, it's experimental because I can find no present python
-written plasmoids and no-one seems to know how to use plasmapkg. In its current form it doubles the install
-of the v4l2 to 2 sites to cover all possibilites. Once I figure what is not required those lines will go and
-it will shrink.
diff --git a/kde-misc/Webcamoid/metadata.xml b/kde-misc/Webcamoid/metadata.xml
deleted file mode 100644
index d8892d7..0000000
--- a/kde-misc/Webcamoid/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>kde</herd>
-<maintainer>
- <email>della5@iinet.com.au</email>
-</maintainer>
-</pkgmetadata>