summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/bup/bup-9999.ebuild')
-rw-r--r--app-backup/bup/bup-9999.ebuild34
1 files changed, 27 insertions, 7 deletions
diff --git a/app-backup/bup/bup-9999.ebuild b/app-backup/bup/bup-9999.ebuild
index 7c4e92b..28b8786 100644
--- a/app-backup/bup/bup-9999.ebuild
+++ b/app-backup/bup/bup-9999.ebuild
@@ -2,12 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
-inherit git eutils
+EAPI=4
+
+EGIT_REPO_URI="git://github.com/apenwarr/${PN}.git
+ http://github.com/apenwarr/${PN}.git"
+inherit git-2 eutils multilib
DESCRIPTION="It backs things up based on the git packfile format"
HOMEPAGE="http://github.com/apenwarr/bup"
-EGIT_REPO_URI="git://github.com/apenwarr/bup"
LICENSE="LGPL-2"
SLOT="0"
@@ -26,18 +28,36 @@ DEPEND="|| (
doc? ( app-text/pandoc )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ # bup doesn't accept --build= option
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --libdir=/usr/"$(get_libdir)"
+
+}
+
src_compile() {
- emake || die "emake failed"
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
+ emake install DESTDIR="${D}"
- dodoc "${D}/usr/share/doc/${PN}"/* && rm -r "${D}/usr/share/doc/${PN}/"
+ dodoc "${D}/usr/share/doc/${PN}"/*
+ rm -r "${D}/usr/share/doc/${PN}/" || die
dodoc README DESIGN
}
src_test() {
- emake test || die "emake test failed"
+ emake test
}