aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-10-05 19:08:42 +0100
committerPaul Healy <lmiphay@gmail.com>2018-10-05 19:08:42 +0100
commita29e8e8d340b781d03715501e4b4b3a5d13b07ad (patch)
tree016021d200d4764036f28b9d031631814a2488fb /app-forensics/lynis
parentrevbump slack (diff)
downloadlmiphay-a29e8e8d340b781d03715501e4b4b3a5d13b07ad.tar.gz
lmiphay-a29e8e8d340b781d03715501e4b4b3a5d13b07ad.tar.bz2
lmiphay-a29e8e8d340b781d03715501e4b4b3a5d13b07ad.zip
add ebuild for latest lynis
Diffstat (limited to 'app-forensics/lynis')
-rw-r--r--app-forensics/lynis/Manifest3
-rw-r--r--app-forensics/lynis/files/lynis.cron-new3
-rw-r--r--app-forensics/lynis/lynis-2.6.9.ebuild50
3 files changed, 56 insertions, 0 deletions
diff --git a/app-forensics/lynis/Manifest b/app-forensics/lynis/Manifest
new file mode 100644
index 0000000..4af766c
--- /dev/null
+++ b/app-forensics/lynis/Manifest
@@ -0,0 +1,3 @@
+AUX lynis.cron-new 70 BLAKE2B 64ffbfa698bc13450503907bd9073a1266075c12fe709a5036b412a6a39e5730de0cf83f52864f7e474506ec5f1aeabf9415f2c0d58a6d7e41847670ce311f91 SHA512 f90592c9adb6617b367c22912ceb984cca9a64c1bfa092efb50f5f9df48b07f61c7e990b969f3871161d92ff28bdb131175d46b334947980b7ead49dd6ff70c7
+DIST lynis-2.6.9.tar.gz 276156 BLAKE2B 2929d17dddb295f66bf78ad48a344c78c1fae5bc9ee5c5ca37fd797556998600043dab00a8fc3abb58886f092c95a86455806768561dc148abc59bef449a440f SHA512 d5af6d6e571b4098c9b03e509c8ac25d73ed9aa86e8e525353c0761c5427ad35c4ef764e0f9c2c3495e2addd3d6229ba1309b803978f6e380f5edae3fef60070
+EBUILD lynis-2.6.9.ebuild 948 BLAKE2B bf6edb25a080382349878f4ee279c638e48c181dc0ba630f6f28e77984d2f9b95773f1eef6dfffa894fce73f355ebb5d6e8fe316d5f082effd286babd56920f5 SHA512 7a9f762e5e5ca0f6d7cd3f3c934d78b44c6c080bd926a0923eb21c6894f56fe27a8f355fd528d5276d2ddbc77967c728fc8e74fd29a7ec6d66edbae7e0644f4c
diff --git a/app-forensics/lynis/files/lynis.cron-new b/app-forensics/lynis/files/lynis.cron-new
new file mode 100644
index 0000000..15a39f1
--- /dev/null
+++ b/app-forensics/lynis/files/lynis.cron-new
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/usr/sbin/lynis --checkall --auditor "automated" --cronjob
diff --git a/app-forensics/lynis/lynis-2.6.9.ebuild b/app-forensics/lynis/lynis-2.6.9.ebuild
new file mode 100644
index 0000000..03c1f53
--- /dev/null
+++ b/app-forensics/lynis/lynis-2.6.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Security and system auditing tool"
+HOMEPAGE="https://cisofy.com/lynis/"
+SRC_URI="https://cisofy.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-shells/bash"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ doman lynis.8
+ dodoc FAQ README
+ newdoc CHANGELOG.md CHANGELOG
+
+ # Remove the old one during the next stabilize progress
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/lynis.cron-new lynis
+
+ dobashcomp extras/bash_completion.d/lynis
+
+ # stricter default perms - bug 507436
+ diropts -m0700
+ insopts -m0600
+
+ insinto /usr/share/${PN}
+ doins -r db/ include/ plugins/
+
+ dosbin lynis
+
+ insinto /etc/${PN}
+ doins default.prf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "A cron script has been installed to ${ROOT}etc/cron.daily/lynis."
+ einfo
+}