aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2020-04-21 21:02:40 +0100
committerPaul Healy <lmiphay@gmail.com>2020-04-21 21:02:40 +0100
commit9bfb6ae162288d86e1debcad7a260770603bfc62 (patch)
treeebe87b056677d933228f73200f8dea2e79a93894 /kde-misc/plasma-custom-desktop-menu/plasma-custom-desktop-menu-2016.01.20.14.10.49-r1.ebuild
parentrevbump firestorm (diff)
downloadlmiphay-9bfb6ae162288d86e1debcad7a260770603bfc62.tar.gz
lmiphay-9bfb6ae162288d86e1debcad7a260770603bfc62.tar.bz2
lmiphay-9bfb6ae162288d86e1debcad7a260770603bfc62.zip
switch to ecm eclass
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'kde-misc/plasma-custom-desktop-menu/plasma-custom-desktop-menu-2016.01.20.14.10.49-r1.ebuild')
-rw-r--r--kde-misc/plasma-custom-desktop-menu/plasma-custom-desktop-menu-2016.01.20.14.10.49-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/kde-misc/plasma-custom-desktop-menu/plasma-custom-desktop-menu-2016.01.20.14.10.49-r1.ebuild b/kde-misc/plasma-custom-desktop-menu/plasma-custom-desktop-menu-2016.01.20.14.10.49-r1.ebuild
new file mode 100644
index 0000000..ade554e
--- /dev/null
+++ b/kde-misc/plasma-custom-desktop-menu/plasma-custom-desktop-menu-2016.01.20.14.10.49-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit ecm
+
+DESCRIPTION="A fully customisable desktop menu for plasma 5"
+HOMEPAGE="https://sourceforge.net/projects/plasma-custom-desktop-menu"
+SRC_URI="mirror://sourceforge/${PN}/plasma-containmentactions-customdesktopmenu-${PV}.tar.gz"
+# Also at:
+# http://kde-apps.org/content/show.php?action=content&content=171299
+# https://github.com/MatMoul/plasma-containmentactions-customdesktopmenu
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ kde-plasma/plasma-workspace
+"
+DEPEND="${RDEPEND}
+"
+S="${WORKDIR}/plasma-containmentactions-customdesktopmenu"
+
+src_install() {
+ default
+ dodoc "${FILESDIR}/example.config"
+ insinto /usr/lib64/qt5/plugins
+ doins ${WORKDIR}/${P}_build/plasma_containmentactions_customdesktopmenu.so
+ insinto /usr/share/kservices5
+ doins plasma-containmentactions-customdesktopmenu.desktop
+}
+
+pkg_postinst() {
+ elog "To enable this launcher:"
+ elog ""
+ elog " Run: kbuildsycoca5"
+ elog ""
+ elog " Right click to your desktop and select Desktop Settings."
+ elog " On mouse actions, you can now choose Custom Desktop Menu."
+ elog ""
+ elog " If new menu is not available, logout/login your session."
+ elog ""
+ elog " Configure in: <Right-Click>->Desktop Settings->Mouse Actions->Custom Desktop Menu [Config]"
+ elog " See installed doc: example.config"
+}