summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opencollada/opencollada-9999.ebuild')
-rw-r--r--media-libs/opencollada/opencollada-9999.ebuild21
1 files changed, 2 insertions, 19 deletions
diff --git a/media-libs/opencollada/opencollada-9999.ebuild b/media-libs/opencollada/opencollada-9999.ebuild
index 832db0b..cbfcc9b 100644
--- a/media-libs/opencollada/opencollada-9999.ebuild
+++ b/media-libs/opencollada/opencollada-9999.ebuild
@@ -2,9 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
-inherit cmake-utils
-inherit subversion
+inherit eutils cmake-utils subversion
DESCRIPTION="OpenCOLLADA is a stream based reader and writer library for COLLADA files"
HOMEPAGE="http://www.opencollada.org/"
@@ -12,7 +10,6 @@ LICENSE="MIT"
ESVN_REPO_URI="http://opencollada.googlecode.com/svn/trunk"
ESVN_PROJECT="opencollada-trunk"
-#ESVN_PATCHES="${FILESDIR}/opencollada-9999-gcc-fixes.patch"
SLOT="0"
KEYWORDS="~amd64"
@@ -21,20 +18,6 @@ DEPEND=">=dev-libs/libxml2-2.7.8-r1"
RDEPEND="${DEPEND}"
src_install() {
+ cmake-utils_src_install
dobin ${CMAKE_BUILD_DIR}/bin/OpenCOLLADAValidator
- dolib ${CMAKE_BUILD_DIR}/lib/libOpenCOLLADABaseUtils.a
- dolib ${CMAKE_BUILD_DIR}/lib/libOpenCOLLADAFramework.a
- dolib ${CMAKE_BUILD_DIR}/lib/libOpenCOLLADASaxFrameworkLoader.a
- dolib ${CMAKE_BUILD_DIR}/lib/libOpenCOLLADAStreamWriter.a
-
- insinto /usr/include/OpenCOLLADA/COLLADABaseUtils
- cp -r ${CMAKE_USE_DIR}/COLLADABaseUtils/include/* ${D}/usr/include/OpenCOLLADA/COLLADABaseUtils/
- insinto /usr/include/OpenCOLLADA/COLLADAFramework
- cp -r ${CMAKE_USE_DIR}/COLLADAFramework/include/* ${D}/usr/include/OpenCOLLADA/COLLADAFramework/
- insinto /usr/include/OpenCOLLADA/COLLADAStreamWriter
- cp -r ${CMAKE_USE_DIR}/COLLADAStreamWriter/include/* ${D}/usr/include/OpenCOLLADA/COLLADAStreamWriter/
- insinto /usr/include/OpenCOLLADA/GeneratedSaxParser
- cp -r ${CMAKE_USE_DIR}/GeneratedSaxParser/include/* ${D}/usr/include/OpenCOLLADA/GeneratedSaxParser/
- insinto /usr/include/OpenCOLLADA/COLLADASaxFrameworkLoader
- cp -r ${CMAKE_USE_DIR}/COLLADASaxFrameworkLoader/include/* ${D}/usr/include/OpenCOLLADA/COLLADASaxFrameworkLoader/
}