summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/android-studio/android-studio-0.8.9.135.1404660.ebuild')
-rw-r--r--dev-util/android-studio/android-studio-0.8.9.135.1404660.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-util/android-studio/android-studio-0.8.9.135.1404660.ebuild b/dev-util/android-studio/android-studio-0.8.9.135.1404660.ebuild
deleted file mode 100644
index d428bc8..0000000
--- a/dev-util/android-studio/android-studio-0.8.9.135.1404660.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/android-studio/android-studio-0.8.1.135.1248636.ebuild,v 1.1 2014/07/05 08:40:37 swift Exp $
-
-EAPI=5
-inherit eutils versionator
-
-RESTRICT="strip"
-QA_TEXTRELS="opt/${P}/bin/libbreakgen.so"
-STUDIO_V=$(get_version_component_range 1-3)
-BUILD_V=$(get_version_component_range 4-5)
-DESCRIPTION="A new Android development environment based on IntelliJ IDEA"
-HOMEPAGE="http://developer.android.com/sdk/installing/studio.html"
-SRC_URI="http://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="app-arch/zip"
-RDEPEND=">=virtual/jdk-1.7"
-S=${WORKDIR}/${PN}
-
-src_install() {
- local dir="/opt/${PN}"
-
- insinto "${dir}"
- doins -r *
- fperms 755 "${dir}/bin/studio.sh" "${dir}/bin/fsnotifier" "${dir}/bin/fsnotifier64"
-
- newicon "bin/idea.png" "${PN}.png"
- make_wrapper ${PN} ${dir}/bin/studio.sh
- make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE"
-}