summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Sanda <ps@twin.jikos.cz>2011-06-18 22:24:43 +0200
committerPavel Sanda <ps@twin.jikos.cz>2011-06-18 22:24:43 +0200
commit77e5757b9c977c624028638731f72c843ebdacf0 (patch)
tree6e94bb71caeb5ac20576de438c735a8c83ddf3a6
parentdigest (diff)
downloadrebutia-77e5757b9c977c624028638731f72c843ebdacf0.tar.gz
rebutia-77e5757b9c977c624028638731f72c843ebdacf0.tar.bz2
rebutia-77e5757b9c977c624028638731f72c843ebdacf0.zip
commit live version of lyx 2.0 ebuild
-rw-r--r--app-office/lyx/Manifest1
-rw-r--r--app-office/lyx/lyx-2.0.9999.ebuild183
2 files changed, 184 insertions, 0 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
index 50b9c88..2dff9a0 100644
--- a/app-office/lyx/Manifest
+++ b/app-office/lyx/Manifest
@@ -2,3 +2,4 @@ AUX 1.6.7-python.patch 906 RMD160 74a2f14445d6b011fe04d06f3bd6710d36ab6351 SHA1
AUX lyx-1.5.0-gentoo.patch 1298 RMD160 69b7ce68234e7f5c2fee708944267f1974aa10d0 SHA1 16c3e6f846c55c3eb5fd9d7da1247a3429efa7a4 SHA256 36be1ea2577cce270319a7a3b4bed92e5925c0e974edda8729bda2179ac8ffe2
AUX lyx.desktop 215 RMD160 13192f0f4e84e870565a3daff7d46c56954ed0fe SHA1 f72f3ff17a3a1b84cbb0aaf12c9e75387879a420 SHA256 b0ffd201e0a2e0cb39a52aadb9921e86fbb31c8d3cac04526371d6606246898c
EBUILD lyx-1.6.9999.ebuild 4194 RMD160 9358460f4d20b53abb9282e209ada592546e7f1d SHA1 9df6b29ef48455295e9dda81818b6ef675595352 SHA256 2a1db7e7a8a0408c0455fea37d1bb9630e3d077d8b0306b50c67d15f5dec06e9
+EBUILD lyx-2.0.9999.ebuild 4608 RMD160 0c37eca4d03b54e15bc14b09b326f10880b99654 SHA1 46ef4d064b7a321dd31bc26eb32bcbc2e68a38dc SHA256 eb2bc88053baa598310e0eeea02da1d0d871879a28e6a0e4e95504f3b1e28e36
diff --git a/app-office/lyx/lyx-2.0.9999.ebuild b/app-office/lyx/lyx-2.0.9999.ebuild
new file mode 100644
index 0000000..fd41530
--- /dev/null
+++ b/app-office/lyx/lyx-2.0.9999.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit qt4-r2 eutils flag-o-matic font python toolchain-funcs subversion
+
+MY_P="${P/_}"
+
+ESVN_REPO_URI=svn://svn.lyx.org/lyx/lyx-devel/branches/BRANCH_2_0_X
+S="${WORKDIR}/${S}"
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
+HOMEPAGE="http://www.lyx.org/"
+#SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/2.0.x/${P}.tar.xz"
+#SRC_URI="ftp://ftp.lyx.org/pub/lyx/devel/lyx-2.0/rc3/${MY_P}.tar.xz"
+#SRC_URI="ftp://ftp.devel.lyx.org/pub/lyx/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cups debug nls latex xetex luatex monolithic-build html rtf dot docbook dia subversion rcs svg gnumeric +hunspell aspell enchant"
+
+LANGS="ar ca cs de da el en es eu fi fr gl he hu ia id it ja nb nn pl pt ro ru sk sr sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+COMMONDEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXrender
+ x11-libs/libXfixes
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ dev-libs/libxml2
+ media-libs/fontconfig
+ media-libs/freetype
+ >=dev-libs/boost-1.34
+ sys-devel/gettext"
+
+RDEPEND="${COMMONDEPEND}
+ || ( dev-texlive/texlive-fontsextra app-text/ptex )
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick )
+ cups? ( net-print/cups )
+ latex? (
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ app-text/noweb
+ app-text/dvipng
+ dev-tex/dvipost
+ dev-tex/chktex
+ app-text/ps2eps
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-science
+ dev-texlive/texlive-genericextra
+ dev-texlive/texlive-fontsrecommended
+ || (
+ dev-tex/latex2html
+ dev-tex/tth
+ dev-tex/hevea
+ dev-tex/tex4ht
+ )
+ )
+ xetex? ( dev-texlive/texlive-xetex )
+ luatex? ( >=dev-texlive/texlive-luatex-2010 )
+ html? ( dev-tex/html2latex )
+ rtf? (
+ dev-tex/latex2rtf
+ app-text/unrtf
+ dev-tex/html2latex
+ )
+ linguas_he? ( dev-tex/culmus-latex )
+ docbook? ( app-text/sgmltools-lite )
+ dot? ( media-gfx/graphviz )
+ dia? ( app-office/dia )
+ subversion? ( dev-vcs/subversion )
+ rcs? ( dev-vcs/rcs )
+ svg? ( || ( gnome-base/librsvg media-gfx/inkscape ) )
+ gnumeric? ( app-office/gnumeric )
+ hunspell? ( app-text/hunspell )
+ aspell? ( app-text/aspell )
+ enchant? ( app-text/enchant )"
+
+DEPEND="${COMMONDEPEND}
+ x11-proto/xproto
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python_set_active_version 2
+ font_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.6.7-python.patch
+ echo "#!/bin/sh" > config/py-compile
+ sed "s:python -tt:$(PYTHON) -tt:g" -i lib/configure.py || die
+}
+
+src_configure() {
+ tc-export CXX
+ #bug 221921
+ export VARTEXFONTS=${T}/fonts
+ ./autogen.sh
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable monolithic-build) \
+ $(use_with hunspell) \
+ $(use_with aspell) \
+ $(use_with enchant) \
+ --without-included-boost --disable-stdlib-debug
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ANNOUNCE NEWS README RELEASE-NOTES UPGRADING "${FONT_S}"/*.txt || die
+
+ if use linguas_he ; then
+ echo "\bind_file cua" > "${T}"/hebrew.bind
+ echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind
+
+ insinto /usr/share/lyx/bind
+ doins "${T}"/hebrew.bind || die
+ fi
+
+ doicon ${PN} "$S/development/Win32/packaging/icons/lyx_32x32.png"
+ make_desktop_entry ${PN} "LyX" "/usr/share/pixmaps/lyx_32x32.png" "Office" "MimeType=application/x-lyx;"
+
+ # fix for bug 91108
+ if use latex ; then
+ dosym ../../../lyx/tex /usr/share/texmf/tex/latex/lyx || die
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+
+ python_convert_shebangs -r 2 "${D}"/usr/share/${PN}
+
+ if use hunspell ; then
+ dosym /usr/share/myspell /usr/share/lyx/dicts
+ dosym /usr/share/myspell /usr/share/lyx/thes
+ fi
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash
+ fi
+
+ # instructions for RTL support. See also bug 168331.
+ if use linguas_he || use linguas_ar; then
+ elog
+ elog "Enabling RTL support in LyX:"
+ elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
+ elog "You must enable RTL support in LyX. To do so start LyX and go to"
+ elog "Tools->Preferences->Language settings->Language"
+ elog "and make sure the \"Right-to-left language support\" is checked"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ if use latex ; then
+ texhash
+ fi
+}