summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/spideroak-bin/spideroak-bin-4.7.9948-r1.ebuild')
-rw-r--r--app-backup/spideroak-bin/spideroak-bin-4.7.9948-r1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/app-backup/spideroak-bin/spideroak-bin-4.7.9948-r1.ebuild b/app-backup/spideroak-bin/spideroak-bin-4.7.9948-r1.ebuild
index 8bb53e4..e99e80e 100644
--- a/app-backup/spideroak-bin/spideroak-bin-4.7.9948-r1.ebuild
+++ b/app-backup/spideroak-bin/spideroak-bin-4.7.9948-r1.ebuild
@@ -22,7 +22,7 @@ IUSE="dbus headless system-libs"
SSL_SLOT="0.9.8"
-DEPEND=""
+DEPEND="dev-util/patchelf"
RDEPEND="
dbus? ( sys-apps/dbus )
!headless? (
@@ -68,7 +68,6 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}"/${PF}-opt-path.patch
use headless && epatch "${FILESDIR}"/${PF}-headless.patch
- epatch "${FILESDIR}"/${PF}-patchelf.patch
# Remove bundled libraries/plugins/python interpreter. Please keep this
# mapping in sync with the RDEPEND system-libs? ( atoms ) above, and the
@@ -114,6 +113,16 @@ src_prepare() {
# Remove bundled python interpreter => dev-lang/python:2.7
rm usr/lib/SpiderOak/py || die "rm py failed"
fi
+
+ # Set RPATH for preserve-libs handling (bug #400979).
+ cd "${S}/usr/lib/SpiderOak" || die
+ local x
+ for x in * ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
}
src_install() {