summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2022-01-20 10:16:07 -0600
committerDaniel Solano Gómez <gentoo@sattvik.com>2022-01-20 10:16:07 -0600
commitafcea55d001621c1379f4e82721b124ae17eb591 (patch)
treea5fd477ebf3376409012d4c19b91996277f19810 /app-containers
parentSync vmware-{modules,workstation} from stefantalpalaru-overlay (diff)
downloadsattvik-afcea55d001621c1379f4e82721b124ae17eb591.tar.gz
sattvik-afcea55d001621c1379f4e82721b124ae17eb591.tar.bz2
sattvik-afcea55d001621c1379f4e82721b124ae17eb591.zip
Update amazon-ecr-credential-helper
Signed-off-by: Daniel Solano <gentoo@sattvik.com>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/amazon-ecr-credential-helper/Manifest5
-rw-r--r--app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.1.0.ebuild31
-rw-r--r--app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.4.0.ebuild31
-rw-r--r--app-containers/amazon-ecr-credential-helper/metadata.xml8
4 files changed, 75 insertions, 0 deletions
diff --git a/app-containers/amazon-ecr-credential-helper/Manifest b/app-containers/amazon-ecr-credential-helper/Manifest
new file mode 100644
index 0000000..3068a61
--- /dev/null
+++ b/app-containers/amazon-ecr-credential-helper/Manifest
@@ -0,0 +1,5 @@
+DIST amazon-ecr-credential-helper-0.1.0.tar.gz 326639 BLAKE2B 7fdccb48f71fff58300e44f692124ceb254240c34dcbffd2bc751a4480e4c11651c41a0da3e658089ce878bbbc9e17c2fe5b12694f8ea0c6a56df747b7b383b4 SHA512 548467bff91a39e0f43bca38286b84064d1f501cea7418baea571cbd103690448027b479ed7e4eea82b309f28d74ed65d4f26e4cf3ed0dc66b2c68cf7c871cb5
+DIST amazon-ecr-credential-helper-0.4.0.tar.gz 1542493 BLAKE2B dbb202324fc68ebdafc933c4e4f951e071a7e608db94519b26dd20ce618a492d0621f7c4f212f0e15d91e167e94ca2507a17bec38321028c1751e662d7faa43e SHA512 6cce35ad9ec77adbc3ec3cd17ffdfe80ce1b3a5f54cf3779010b870ee655e3ceb8f24f9a4ce86197e3959b611a4595862809e6773d487bed8bc590d4d34209c4
+EBUILD amazon-ecr-credential-helper-0.1.0.ebuild 831 BLAKE2B 9a5be71a4dffed143ed36e5e79317c2cf869e07dc1dcd1731e2675a83d6748e936e98d40a1962be3f2e726da9eb01a54ec3705dc2560cdfca4f6e3f8fa0ede3a SHA512 751b6831c1ef680c43fead4bee45214d67e6286f9f4b2c4e409184dbd153e81a22b87c23a712fb624f07fa0b76e6d0b2d3fa91785b40c3468fdfaa991eadc354
+EBUILD amazon-ecr-credential-helper-0.4.0.ebuild 828 BLAKE2B ec79deb5e98352b46f40c0fa4f6b395351af4acb60c92017d0eba4c15f93e8b0e1021a4828b6b4b6edb5984849508ca70cb350143b096e66f3a78dddd6a3578c SHA512 293df1b98487bbc0123761ae221ebf2ab61afd292d450d23fa17feadfc43388a018fab3ff56ff4136e81f99272cf87f7899d5984910284d91ef5aba39503aab0
+MISC metadata.xml 254 BLAKE2B 2b84fe691bb03bd3bab9b940d8c95beba569d018f83451a447c3fe65bc56c9c4d71c277036fd1e45235fd1a972532027ab1b3726c79827c7239655df75580ea7 SHA512 0590e4d0253e87a4cace2209a206ed90a39d2ccc182fd531e87318fb689eb280a3aa1ab731db3c09d48ec47822e5086dbeed6a3ffd9a074f94b1d07b914bc4e0
diff --git a/app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.1.0.ebuild b/app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.1.0.ebuild
new file mode 100644
index 0000000..d3ef3a9
--- /dev/null
+++ b/app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/awslabs/${PN}
+
+EGIT_COMMIT="v${PV}"
+SRC_URI="https://github.com/awslabs/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+# inherit golang-build golang-vcs-snapshot
+inherit golang-base golang-vcs-snapshot
+
+DESCRIPTION="Automatically gets credentials for Amazon ECR on docker push/docker pull"
+HOMEPAGE="https://github.com/awslabs/amazon-ecr-credential-helper"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ ego_pn_check
+ set -- env GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go build -v -work -x ${EGO_BUILD_FLAGS} ${EGO_PN}/ecr-login/cli/docker-credential-ecr-login
+ echo "$@"
+ "$@" || die
+}
+
+src_install() {
+ cd ${EGO_PN}
+ dobin docker-credential-ecr-login
+}
diff --git a/app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.4.0.ebuild b/app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.4.0.ebuild
new file mode 100644
index 0000000..f4b4b1e
--- /dev/null
+++ b/app-containers/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/awslabs/${PN}
+
+EGIT_COMMIT="v${PV}"
+SRC_URI="https://github.com/awslabs/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+# inherit golang-build golang-vcs-snapshot
+inherit golang-base golang-vcs-snapshot
+
+DESCRIPTION="Automatically gets credentials for Amazon ECR on docker push/docker pull"
+HOMEPAGE="https://github.com/awslabs/amazon-ecr-credential-helper"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ ego_pn_check
+ set -- env GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go build -v -work -x ${EGO_BUILD_FLAGS} ${EGO_PN}/ecr-login/cli/docker-credential-ecr-login
+ echo "$@"
+ "$@" || die
+}
+
+src_install() {
+ cd ${EGO_PN}
+ dobin docker-credential-ecr-login
+}
diff --git a/app-containers/amazon-ecr-credential-helper/metadata.xml b/app-containers/amazon-ecr-credential-helper/metadata.xml
new file mode 100644
index 0000000..070e23e
--- /dev/null
+++ b/app-containers/amazon-ecr-credential-helper/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@sattvik.com</email>
+ <name>Daniel Solano Gómez</name>
+ </maintainer>
+</pkgmetadata>