summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/asciidoctor-pdf')
-rw-r--r--dev-ruby/asciidoctor-pdf/Manifest3
-rw-r--r--dev-ruby/asciidoctor-pdf/asciidoctor-pdf-2.3.0.ebuild48
-rw-r--r--dev-ruby/asciidoctor-pdf/metadata.xml19
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor-pdf/Manifest b/dev-ruby/asciidoctor-pdf/Manifest
new file mode 100644
index 0000000..7464747
--- /dev/null
+++ b/dev-ruby/asciidoctor-pdf/Manifest
@@ -0,0 +1,3 @@
+DIST asciidoctor-pdf-2.3.0.tar.gz 6481184 BLAKE2B d304aa7f2833897c525696dad6bf9fdfae3dc135351750cc27707f27e4a3c82c4aebff8ef2fb7241b6d903ff0901bb224c9321cdbbef4c16936fb9484ac56290 SHA512 da55e2ea20d7e076fa9068d9582d1d2a9ed169410f2b1fc3fe5b3b47b7194f9f9552d793c0d9d0c80ff8eb732695c1c2abbee7a325ab507d62761e05c0ea1a14
+EBUILD asciidoctor-pdf-2.3.0.ebuild 1135 BLAKE2B 273f22ae9e6009ec9f8081c14ba50c129bff723f9d1c7e306f2e29185d48e19e07fbf807cfbae544c381725ec300c9f686d4e42703d19612f39496d0fc690996 SHA512 5ad4ace81f8c64c8dc27966d3a2cab83c12fd146f290a1cfb0d6d070ff7c4b4d4958896af51d9c1b72f332e880d3f48e22a1f0286546aad6b134851e011da9ec
+MISC metadata.xml 796 BLAKE2B b27ad40b0ebd92b01ec7fe1c2eeb69d68ce7c9549d4331b10c62d939052f07e395ae16ac4d40fa7237ef6eacba4026ce2636490716ff4aa20ed6adbb831237b1 SHA512 5bc29feb57a3c1e7560a6a7e5045bbc30da1344281ae031a5855c918634ff80f7db7d82b21ee297f315b76a14470eea2b8da6c66e0f36027d2a8168896b4b3fc
diff --git a/dev-ruby/asciidoctor-pdf/asciidoctor-pdf-2.3.0.ebuild b/dev-ruby/asciidoctor-pdf/asciidoctor-pdf-2.3.0.ebuild
new file mode 100644
index 0000000..027a42e
--- /dev/null
+++ b/dev-ruby/asciidoctor-pdf/asciidoctor-pdf-2.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="CUCUMBER_PUBLISH_QUIET=true test features"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_GEMSPEC="asciidoctor-pdf.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A native PDF converter for AsciiDoc based on Asciidoctor and Prawn"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor-pdf"
+SRC_URI="https://github.com/asciidoctor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# rake have no task test, skipping for now
+RESTRICT=test
+
+ruby_add_rdepend "
+ >=dev-ruby/asciidoctor-2.0
+ >=dev-ruby/concurrent-ruby-1.1
+ >=dev-ruby/matrix-0.4
+ >=dev-ruby/prawn-2.4.0
+ >=dev-ruby/prawn-icon-3.0.0
+ >=dev-ruby/prawn-svg-0.32.0
+ >=dev-ruby/prawn-table-0.2.0
+ >=dev-ruby/prawn-templates-0.1.0
+ >=dev-ruby/treetop-1.6.0
+ "
+
+all_ruby_prepare() {
+ rm Gemfile || die
+
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+}
diff --git a/dev-ruby/asciidoctor-pdf/metadata.xml b/dev-ruby/asciidoctor-pdf/metadata.xml
new file mode 100644
index 0000000..d5cd3a9
--- /dev/null
+++ b/dev-ruby/asciidoctor-pdf/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vowstar@gmail.com</email>
+ <name>Huang Rui</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">asciidoctor/asciidoctor-pdf</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Asciidoctor PDF is a native PDF converter for AsciiDoc that serves the
+ pdf backend. It bypasses the step of generating an intermediary format
+ such as DocBook, Apache FO, or LaTeX in order to produce PDF.
+ Instead, you use Asciidoctor PDF to convert your documents directly
+ from AsciiDoc to PDF with Asciidoctor. The aim of this library is to
+ take the pain out of creating PDF documents from AsciiDoc.
+ </longdescription>
+</pkgmetadata>