aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2013-09-02 20:59:04 +0100
committerStuart Shelton <stuart@shelton.me>2013-09-02 20:59:04 +0100
commit2e7206b87955147507b348f20811aa1f5f691275 (patch)
tree582a07082b66da7a3bd3b1d157526dd2800dc45a /app-pda
parentdev-ruby/rake-10.1.0 (diff)
downloadsrcshelton-2e7206b87955147507b348f20811aa1f5f691275.tar.gz
srcshelton-2e7206b87955147507b348f20811aa1f5f691275.tar.bz2
srcshelton-2e7206b87955147507b348f20811aa1f5f691275.zip
app-pda/ipheth-pair-9999
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/ipheth-pair/Manifest2
-rw-r--r--app-pda/ipheth-pair/files/Makefile.patch19
-rw-r--r--app-pda/ipheth-pair/ipheth-pair-9999.ebuild32
3 files changed, 53 insertions, 0 deletions
diff --git a/app-pda/ipheth-pair/Manifest b/app-pda/ipheth-pair/Manifest
new file mode 100644
index 00000000..715c01b3
--- /dev/null
+++ b/app-pda/ipheth-pair/Manifest
@@ -0,0 +1,2 @@
+AUX Makefile.patch 599 SHA256 5a9f0b45bfe397501d5503ff94fed6f275f9d7567051dd9a8fd60feeeaa519d2 SHA512 d58dfefd8c6f2e8dcbcd26bfee3cbbbec6b4f589f644cb261ce03adc94eae7cd5b2aee82ace091f6d35e24915d0ce712684220bebec22ff0f8479ffb9d4d25ad WHIRLPOOL 9d6ecb2115b26d59d8f1e3b0f0876c25e96a41e10aa313808243a78ef94e43d1b34ee5c0d25e4005ba0f851cae70488c3ae45daddd69136e053f4b2fc5598379
+EBUILD ipheth-pair-9999.ebuild 690 SHA256 3fa896db490607fe1511faf1e8ed3cf80d75e39a5281b9f8368362612e38afb5 SHA512 461494b28646156ef38a5e32379d164596ec8530a481969938d30103125933fa63ff92912f5261f22f39adffc36d7230733a01a8dfa2458c948a8bf60c696bbf WHIRLPOOL c69307fd998abd2b1cb62fb5fc5cc646fee68966ca3cf6216232e52efaa5b6b7f8803bd21914ec5f00fbc7adcfb5d396cf3da29c8a91bd28c2a23b543f371839
diff --git a/app-pda/ipheth-pair/files/Makefile.patch b/app-pda/ipheth-pair/files/Makefile.patch
new file mode 100644
index 00000000..6ec0cd4b
--- /dev/null
+++ b/app-pda/ipheth-pair/files/Makefile.patch
@@ -0,0 +1,19 @@
+--- ipheth-pair/Makefile.orig 2010-02-23 10:35:56.000000000 +0200
++++ ipheth-pair/Makefile 2010-02-23 10:37:02.099913826 +0200
+@@ -1,4 +1,3 @@
+-CFLAGS += -Wall -O2
+ LDLIBS += -limobiledevice
+
+ all: ipheth-pair
+@@ -6,9 +5,8 @@
+ ipheth-pair: ipheth-pair.o
+
+ install:
+- install -m 0755 ipheth-pair /lib/udev/
+- install -m 0644 90-iphone-tether.rules /etc/udev/rules.d
+- /sbin/udevadm control --reload-rules
++ install -D -m 0755 ipheth-pair ${DESTDIR}/lib/udev/ipeth-pair
++ install -D -m 0644 90-iphone-tether.rules ${DESTDIR}/etc/udev/rules.d/90-iphone-tether.rules
+
+ clean:
+ rm -f *.o ipheth-pair
diff --git a/app-pda/ipheth-pair/ipheth-pair-9999.ebuild b/app-pda/ipheth-pair/ipheth-pair-9999.ebuild
new file mode 100644
index 00000000..4e86e5eb
--- /dev/null
+++ b/app-pda/ipheth-pair/ipheth-pair-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git autotools
+
+DESCRIPTION="iPhone USB Ethernet Driver for Linux pairing helper"
+HOMEPAGE="http://giagio.com/wiki/moin.cgi/iPhoneEthernetDriver"
+EGIT_REPO_URI="git://github.com/dgiagio/ipheth.git/"
+EGIT_PROJECT="ipheth"
+
+EGIT_PATCHES="${FILESDIR}/Makefile.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="app-pda/libimobiledevice"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake -C ipheth-pair || die
+}
+
+src_install() {
+ emake -C ipheth-pair DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ udevadm control --reload-rules && udevadm trigger
+}