aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2016-11-13 13:16:30 +0000
committerStuart Shelton <stuart@shelton.me>2016-11-13 13:16:30 +0000
commit0fb43887ba2e4e9a5652923cf2d399f3b72aa68f (patch)
tree462aea53e79df97070e6810902fa5fb3dbfc2564 /sys-devel/llvm/llvm-3.5.2.ebuild
parentUpdate net-misc/openssh-7.3_p1-r6 (diff)
downloadsrcshelton-0fb43887ba2e4e9a5652923cf2d399f3b72aa68f.tar.gz
srcshelton-0fb43887ba2e4e9a5652923cf2d399f3b72aa68f.tar.bz2
srcshelton-0fb43887ba2e4e9a5652923cf2d399f3b72aa68f.zip
Update sys-devel/llvm-3.5.0, sys-devel/llvm-3.5.2, sys-devel/llvm-3.7.1-r3, sys-devel/llvm-3.8.1, sys-devel/llvm-3.8.1-r2
Diffstat (limited to 'sys-devel/llvm/llvm-3.5.2.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.5.2.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sys-devel/llvm/llvm-3.5.2.ebuild b/sys-devel/llvm/llvm-3.5.2.ebuild
index 69224dd1..ebd9edbc 100644
--- a/sys-devel/llvm/llvm-3.5.2.ebuild
+++ b/sys-devel/llvm/llvm-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id: 635a9209e3ee7f00d616032a0807475e07b5fa18 $
+# $Id: 303f969e92527d2596c05e52752f07c65712eabc $
EAPI=5
@@ -87,7 +87,7 @@ S=${WORKDIR}/${P}.src
# so why did it call itself ninja in the first place?
CMAKE_MAKEFILE_GENERATOR=emake
-pkg_pretend() {
+check_space() {
# in megs
# !clang !debug !multitarget -O2 400
# !clang !debug multitarget -O2 550
@@ -135,8 +135,12 @@ pkg_pretend() {
fi
}
+pkg_pretend() {
+ check_space
+}
+
pkg_setup() {
- pkg_pretend
+ check_space
}
src_unpack() {