summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-08-03 13:56:20 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-08-03 13:56:20 +0000
commit018c98b85f496508812089fcd2fd4b9fa8324936 (patch)
tree608b6f5ee74b40a2210f4605ea2267b9ac2e170f /app-admin
parentAdd USE=gtk3 (bug #479618 by Nikoli). (diff)
downloadgentoo-2-018c98b85f496508812089fcd2fd4b9fa8324936.tar.gz
gentoo-2-018c98b85f496508812089fcd2fd4b9fa8324936.tar.bz2
gentoo-2-018c98b85f496508812089fcd2fd4b9fa8324936.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webapp-config/ChangeLog8
-rw-r--r--app-admin/webapp-config/webapp-config-1.51.ebuild69
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild16
3 files changed, 80 insertions, 13 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index 65838baada63..c93f1de30004 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/webapp-config
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.89 2013/07/05 00:29:10 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.90 2013/08/03 13:56:20 blueness Exp $
+
+*webapp-config-1.51 (03 Aug 2013)
+
+ 03 Aug 2013; Anthony G. Basile <blueness@gentoo.org>
+ +webapp-config-1.51.ebuild, webapp-config-9999.ebuild:
+ Version bump
05 Jul 2013; Anthony G. Basile <blueness@gentoo.org>
webapp-config-9999.ebuild:
diff --git a/app-admin/webapp-config/webapp-config-1.51.ebuild b/app-admin/webapp-config/webapp-config-1.51.ebuild
new file mode 100644
index 000000000000..a3ca993a782b
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.51.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.51.ebuild,v 1.1 2013/08/03 13:56:20 blueness Exp $
+
+EAPI="5"
+
+# We need to fix 'import md5' for the tests before
+# we can be 3.x compat. Uncomment when done.
+#PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+if [[ ${PV} = 9999* ]]
+then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/${PN}.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://sourceforge.net/projects/webapp-config/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="app-text/xmlto"
+
+python_compile_all() {
+ emake -C doc/
+}
+
+python_install() {
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils-r1_python_install --install-scripts="/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/vhosts
+ doins config/webapp-config
+
+ keepdir /usr/share/webapps
+ keepdir /var/db/webapps
+
+ dodoc AUTHORS
+ doman doc/*.[58]
+ dohtml doc/*.[58].html
+}
+
+python_test() {
+ PYTHONPATH="." "${PYTHON}" WebappConfig/tests/dtest.py \
+ || die "Testing failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ elog "Now that you have upgraded webapp-config, you **must** update your"
+ elog "config files in /etc/vhosts/webapp-config before you emerge any"
+ elog "packages that use webapp-config."
+}
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 685a54fb8fd7..666f64919cd9 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-9999.ebuild,v 1.2 2013/07/05 00:29:10 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-9999.ebuild,v 1.3 2013/08/03 13:56:20 blueness Exp $
EAPI="5"
@@ -30,16 +30,6 @@ SLOT="0"
DEPEND="app-text/xmlto"
-# We can't use-dep on portage for 9999 else we make repoman angry!
-if [[ ${PV} = 9999* ]]
-then
- IUSE=""
- RDEPEND=""
-else
- IUSE="+portage"
- RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
-fi
-
python_compile_all() {
emake -C doc/
}
@@ -54,13 +44,15 @@ python_install() {
}
python_install_all() {
+ distutils-r1_python_install_all
+
insinto /etc/vhosts
doins config/webapp-config
keepdir /usr/share/webapps
keepdir /var/db/webapps
- dodoc AUTHORS TODO
+ dodoc AUTHORS
doman doc/*.[58]
dohtml doc/*.[58].html
}