summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 14:19:23 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 14:19:23 +0000
commit519d935b531ef52927f46676af55135e76cde8f4 (patch)
tree619eb59f61b3a5e08c0d6bcc40995e6d0e919f83 /app-office/dia2code
parentsanitize patch so it doesn't get mangled by cvs (#55319) (Manifest recommit) (diff)
downloadgentoo-2-519d935b531ef52927f46676af55135e76cde8f4.tar.gz
gentoo-2-519d935b531ef52927f46676af55135e76cde8f4.tar.bz2
gentoo-2-519d935b531ef52927f46676af55135e76cde8f4.zip
change glibc to libc
Diffstat (limited to 'app-office/dia2code')
-rw-r--r--app-office/dia2code/dia2code-0.8.1.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/app-office/dia2code/dia2code-0.8.1.ebuild b/app-office/dia2code/dia2code-0.8.1.ebuild
index b1dd0e5f07b2..a982623ed48d 100644
--- a/app-office/dia2code/dia2code-0.8.1.ebuild
+++ b/app-office/dia2code/dia2code-0.8.1.ebuild
@@ -1,33 +1,32 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia2code/dia2code-0.8.1.ebuild,v 1.12 2004/06/24 22:39:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia2code/dia2code-0.8.1.ebuild,v 1.13 2004/06/28 14:15:53 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="Convert UML diagrams produced with Dia to various source code flavours."
+HOMEPAGE="http://dia2code.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://dia2code.sourceforge.net"
-KEYWORDS="x86 ppc amd64 sparc"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ppc sparc amd64"
+IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
dev-libs/libxml2"
-
RDEPEND="${DEPEND}
>=app-office/dia-0.90.0"
-
src_compile () {
# libxml2 header fix
- CFLAGS="${CFLAGS} -I/usr/include/libxml2/libxml"
- ./configure --prefix=/usr \
- --host="${CHOST}"
+ append-flags -I/usr/include/libxml2/libxml
+ econf || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog README TODO
doman dia2code.1
}
-