summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Conrad Tilstra <michael@gentoo.org>2001-04-24 22:58:35 +0000
committerMichael Conrad Tilstra <michael@gentoo.org>2001-04-24 22:58:35 +0000
commite36c8cbf03ae502d8ca437140bd0d3040a314173 (patch)
treef599e9b91499d64ae05adebadb5f44257bc2265d /app-text/dictd-vera
parent- added dictionary databases for dictd (diff)
downloadgentoo-2-e36c8cbf03ae502d8ca437140bd0d3040a314173.tar.gz
gentoo-2-e36c8cbf03ae502d8ca437140bd0d3040a314173.tar.bz2
gentoo-2-e36c8cbf03ae502d8ca437140bd0d3040a314173.zip
- fixed a bug in a pkg_postinst().
- added a pkg_postrm().
Diffstat (limited to 'app-text/dictd-vera')
-rw-r--r--app-text/dictd-vera/dictd-vera-1.7.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-text/dictd-vera/dictd-vera-1.7.ebuild b/app-text/dictd-vera/dictd-vera-1.7.ebuild
index f50a62557524..9ca3ca8bcbaa 100644
--- a/app-text/dictd-vera/dictd-vera-1.7.ebuild
+++ b/app-text/dictd-vera/dictd-vera-1.7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-vera/dictd-vera-1.7.ebuild,v 1.1 2001/04/24 22:07:29 michael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-vera/dictd-vera-1.7.ebuild,v 1.2 2001/04/24 22:58:35 michael Exp $
#P=
A=vera_1.7.tar.gz
@@ -28,5 +28,12 @@ __EOF__
fi
}
+pkg_postrm() {
+if [ -f /etc/dict/dictd.conf ]; then
+ cat /etc/dict/dictd.conf | sed -e '/vera/d' > /etc/dict/dictd.conf.$$
+ mv /etc/dict/dictd.conf.$$ /etc/dict/dictd.conf
+fi
+}
+
# vim: ai et sw=4 ts=4