summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-22 22:36:12 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-22 22:36:12 +0000
commit7126948b1c4c8ad9c893f8f2be1b287c9440f0bd (patch)
treeaa09640a886caf15730a9a1e4bfeeb64514ad357 /app-text/docbook-xsl-stylesheets
parentAdd icedtea6(-bin) as possible jdk's for jpeg support. (diff)
downloadgentoo-2-7126948b1c4c8ad9c893f8f2be1b287c9440f0bd.tar.gz
gentoo-2-7126948b1c4c8ad9c893f8f2be1b287c9440f0bd.tar.bz2
gentoo-2-7126948b1c4c8ad9c893f8f2be1b287c9440f0bd.zip
Version bump, added tests like for docbook-xsl-ns but restrict them for now since the Makefile is broken.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text/docbook-xsl-stylesheets')
-rw-r--r--app-text/docbook-xsl-stylesheets/ChangeLog11
-rw-r--r--app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.75.0.ebuild67
2 files changed, 76 insertions, 2 deletions
diff --git a/app-text/docbook-xsl-stylesheets/ChangeLog b/app-text/docbook-xsl-stylesheets/ChangeLog
index 7b28ee835dd9..d9ee1b92f464 100644
--- a/app-text/docbook-xsl-stylesheets/ChangeLog
+++ b/app-text/docbook-xsl-stylesheets/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/docbook-xsl-stylesheets
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-xsl-stylesheets/ChangeLog,v 1.88 2008/10/05 10:11:50 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-xsl-stylesheets/ChangeLog,v 1.89 2009/05/22 22:36:12 flameeyes Exp $
+
+*docbook-xsl-stylesheets-1.75.0 (22 May 2009)
+
+ 22 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +docbook-xsl-stylesheets-1.75.0.ebuild:
+ Version bump, added tests like for docbook-xsl-ns but restrict them for
+ now since the Makefile is broken.
05 Oct 2008; Diego Pettenò <flameeyes@gentoo.org>
docbook-xsl-stylesheets-1.74.0.ebuild:
diff --git a/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.75.0.ebuild b/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.75.0.ebuild
new file mode 100644
index 000000000000..7f586813bea2
--- /dev/null
+++ b/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.75.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.75.0.ebuild,v 1.1 2009/05/22 22:36:12 flameeyes Exp $
+
+DESCRIPTION="XSL Stylesheets for Docbook"
+HOMEPAGE="http://wiki.docbook.org/topic/DocBookXslStylesheets"
+SRC_URI="mirror://sourceforge/docbook/docbook-xsl-${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-libs/libxml2
+ dev-libs/libxslt )"
+
+RDEPEND=">=app-text/build-docbook-catalog-1.1"
+
+S=${WORKDIR}/docbook-xsl-${PV}
+
+# Makefile is broken in this release
+RESTRICT=test
+
+# The makefile runs tests, not builds.
+src_compile() { :; }
+
+src_test() {
+ emake check || die "test failed"
+}
+
+src_install() {
+ # Create the installation directory
+ DEST="/usr/share/sgml/docbook/xsl-stylesheets"
+ insinto ${DEST}
+
+ local i
+ for sheet in $(find . -maxdepth 1 -mindepth 1 -type d); do
+ i=$(basename $sheet)
+ cd "${S}"/${i}
+ for doc in ChangeLog README; do
+ if [ -e "$doc" ]; then
+ mv ${doc} ${doc}.${i}
+ dodoc ${doc}.${i}
+ rm ${doc}.${i}
+ fi
+ done
+
+ doins -r "${S}"/${i}
+ done
+
+ # Install misc. docs
+ # The changelog is now zipped, and copied as the RELEASE-NOTES, so we
+ # don't need to install it
+ cd "${S}"
+ dodoc AUTHORS BUGS NEWS README RELEASE-NOTES.txt TODO
+ doins VERSION
+}
+
+pkg_postinst() {
+ build-docbook-catalog
+}
+
+pkg_postrm() {
+ build-docbook-catalog
+}