summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-12-18 09:08:11 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-12-18 09:08:11 +0000
commitfe34f0470d05bf3eb959c59761b1225a31a5160d (patch)
treefcbab4af0f1dbc56a7587870bc21951f40eaaeef /dev-games/irrlicht/files
parentVersion bump to 4.0.10 ; dropping old versions (diff)
downloadgentoo-2-fe34f0470d05bf3eb959c59761b1225a31a5160d.tar.gz
gentoo-2-fe34f0470d05bf3eb959c59761b1225a31a5160d.tar.bz2
gentoo-2-fe34f0470d05bf3eb959c59761b1225a31a5160d.zip
Version bump
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.9 i686)
Diffstat (limited to 'dev-games/irrlicht/files')
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.5-config.patch26
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.5-demoMake.patch20
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-games/irrlicht/files/irrlicht-1.5-config.patch b/dev-games/irrlicht/files/irrlicht-1.5-config.patch
new file mode 100644
index 000000000000..fbb1cab1ac7b
--- /dev/null
+++ b/dev-games/irrlicht/files/irrlicht-1.5-config.patch
@@ -0,0 +1,26 @@
+--- include/IrrCompileConfig.h
++++ include/IrrCompileConfig.h
+@@ -113,7 +113,6 @@
+ //! Define _IRR_USE_NON_SYSTEM_ZLIB_ to let irrlicht use the zlib which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the zlib installed in the system.
+ This is only used when _IRR_COMPILE_WITH_ZLIB_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_ZLIB_
+
+
+ //! Define _IRR_COMPILE_WITH_JPEGLIB_ to enable compiling the engine using libjpeg.
+@@ -124,7 +123,6 @@
+ //! Define _IRR_USE_NON_SYSTEM_JPEG_LIB_ to let irrlicht use the jpeglib which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the jpeg lib installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBJPEG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_JPEG_LIB_
+
+
+ //! Define _IRR_COMPILE_WITH_LIBPNG_ to enable compiling the engine using libpng.
+@@ -135,7 +133,6 @@
+ //! Define _IRR_USE_NON_SYSTEM_LIBPNG_ to let irrlicht use the libpng which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the libpng installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBPNG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_LIB_PNG_
+
+
+ //! Define _IRR_D3D_NO_SHADER_DEBUGGING to disable shader debugging in D3D9
diff --git a/dev-games/irrlicht/files/irrlicht-1.5-demoMake.patch b/dev-games/irrlicht/files/irrlicht-1.5-demoMake.patch
new file mode 100644
index 000000000000..ba8a3e2495fb
--- /dev/null
+++ b/dev-games/irrlicht/files/irrlicht-1.5-demoMake.patch
@@ -0,0 +1,20 @@
+--- examples/Demo/Makefile
++++ examples/Demo/Makefile
+@@ -2,7 +2,7 @@
+ Target = Demo
+ Sources = CDemo.cpp CMainMenu.cpp main.cpp
+
+-CPPFLAGS = -I../../include -I/usr/X11R6/include
++CPPFLAGS = -I/usr/include/irrlicht
+ CXXFLAGS = -Wall -O3 -ffast-math
+
+ ifeq ($(HOSTTYPE), x86_64)
+@@ -13,7 +13,7 @@
+
+ # target specific settings
+ all_linux: SYSTEM=Linux
+-all_linux: LDFLAGS = -L/usr/X11R6/lib$(LIBSELECT) -L../../lib/$(SYSTEM) -lIrrlicht -lGL -lXxf86vm -lXext -lX11
++all_linux: LDFLAGS = -lIrrlicht -lGL -lXxf86vm -lXext -lX11 -lpng -ljpeg
+
+ all_win32 clean_win32: SYSTEM=Win32-gcc
+ all_win32: LDFLAGS = -L../../lib/$(SYSTEM) -lIrrlicht -lopengl32 -lglu32 -lm