summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-24 22:22:01 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-24 22:22:01 +0000
commit105baa60e34f9337d5af0de872ed99fb0ddba176 (patch)
treefc0aa4da36a83f0105048bb400601429b1877de4 /dev-games
parentfix permissions #27164 (diff)
downloadgentoo-2-105baa60e34f9337d5af0de872ed99fb0ddba176.tar.gz
gentoo-2-105baa60e34f9337d5af0de872ed99fb0ddba176.tar.bz2
gentoo-2-105baa60e34f9337d5af0de872ed99fb0ddba176.zip
properly install env.d and fix perms #27164
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild8
-rw-r--r--dev-games/crystalspace/crystalspace-20030413-r1.ebuild4
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild b/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild
index d3958e3e72bd..a55e4a79daab 100644
--- a/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild
+++ b/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild,v 1.5 2003/08/18 01:13:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild,v 1.6 2003/08/24 22:21:58 vapier Exp $
inherit cvs
ECVS_SERVER="cvs.sourceforge.net:/cvsroot/crystal"
@@ -43,5 +43,9 @@ src_install() {
make INSTALL_DIR=${D}/${CRYSTAL_PREFIX} install || die
dodir /usr/bin
dosym ${CRYSTAL_PREFIX}/bin/cs-config /usr/bin/cs-config
- echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > 90crystalspace
+ find ${D}/${CRYSTAL_PREFIX} -type f -exec chmod a+r '{}' \;
+ find ${D}/${CRYSTAL_PREFIX} -type d -exec chmod a+rx '{}' \;
+ chmod a+rx ${D}/${CRYSTAL_PREFIX}/{bin,lib}/*
+ dodir /etc/env.d
+ echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > ${D}/etc/env.d/90crystalspace
}
diff --git a/dev-games/crystalspace/crystalspace-20030413-r1.ebuild b/dev-games/crystalspace/crystalspace-20030413-r1.ebuild
index 81b1e40f3ac6..41985a0e55a0 100644
--- a/dev-games/crystalspace/crystalspace-20030413-r1.ebuild
+++ b/dev-games/crystalspace/crystalspace-20030413-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-20030413-r1.ebuild,v 1.8 2003/08/24 22:20:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-20030413-r1.ebuild,v 1.9 2003/08/24 22:22:01 vapier Exp $
DESCRIPTION="portable 3D Game Development Kit written in C++"
SRC_URI="mirror://gentoo/distfiles/${P}.tar.gz"
@@ -44,5 +44,5 @@ src_install() {
find ${D}/${CRYSTAL_PREFIX} -type d -exec chmod a+rx '{}' \;
chmod a+rx ${D}/${CRYSTAL_PREFIX}/{bin,lib}/*
dodir /etc/env.d
- echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > 90crystalspace
+ echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > ${D}/etc/env.d/90crystalspace
}