summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-02-11 19:45:41 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-02-11 19:45:41 +0000
commitb6e9bd94a02e4126522af9173db4425c7cf26737 (patch)
tree42d9b56d824fb32fa21b433cd993d2455d67341f /dev-php
parent Version bumped. (Manifest recommit) (diff)
downloadgentoo-2-b6e9bd94a02e4126522af9173db4425c7cf26737.tar.gz
gentoo-2-b6e9bd94a02e4126522af9173db4425c7cf26737.tar.bz2
gentoo-2-b6e9bd94a02e4126522af9173db4425c7cf26737.zip
cleanup
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/groupoffice/files/digest-groupoffice-1.932
-rw-r--r--dev-php/groupoffice/files/digest-groupoffice-1.942
-rw-r--r--dev-php/groupoffice/files/digest-groupoffice-1.952
-rw-r--r--dev-php/groupoffice/groupoffice-1.93.ebuild60
-rw-r--r--dev-php/groupoffice/groupoffice-1.94.ebuild65
-rw-r--r--dev-php/groupoffice/groupoffice-1.95.ebuild65
6 files changed, 0 insertions, 196 deletions
diff --git a/dev-php/groupoffice/files/digest-groupoffice-1.93 b/dev-php/groupoffice/files/digest-groupoffice-1.93
deleted file mode 100644
index 4a923c619ca7..000000000000
--- a/dev-php/groupoffice/files/digest-groupoffice-1.93
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 0ef76e6e1193a7ce12afb508cd735df9 groupoffice-1.93.tar.gz 788838
-MD5 4ee2188438e2a98cf17d6b47796ec30a GO-theme-crystal-1.93.tar.gz 286777
diff --git a/dev-php/groupoffice/files/digest-groupoffice-1.94 b/dev-php/groupoffice/files/digest-groupoffice-1.94
deleted file mode 100644
index 06c4df09e04f..000000000000
--- a/dev-php/groupoffice/files/digest-groupoffice-1.94
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 8b860e4a048906f7eb049b5e539f364c groupoffice-1.94.tar.gz 827064
-MD5 4ee2188438e2a98cf17d6b47796ec30a GO-theme-crystal-1.93.tar.gz 286777
diff --git a/dev-php/groupoffice/files/digest-groupoffice-1.95 b/dev-php/groupoffice/files/digest-groupoffice-1.95
deleted file mode 100644
index 101c092c0919..000000000000
--- a/dev-php/groupoffice/files/digest-groupoffice-1.95
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 535c0af53daa333a4cea21fb5c3243b3 groupoffice-1.95.tar.gz 1128729
-MD5 4ee2188438e2a98cf17d6b47796ec30a GO-theme-crystal-1.93.tar.gz 286777
diff --git a/dev-php/groupoffice/groupoffice-1.93.ebuild b/dev-php/groupoffice/groupoffice-1.93.ebuild
deleted file mode 100644
index 6fa764aa1cec..000000000000
--- a/dev-php/groupoffice/groupoffice-1.93.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/groupoffice/groupoffice-1.93.ebuild,v 1.5 2004/01/08 08:40:44 robbat2 Exp $
-
-inherit webapp-apache
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Group-Office is a powerfull modular Intranet application framework. It runs *nix using PHP and has several database support."
-HOMEPAGE="http://group-office.sourceforge.net/"
-SRC_URI="mirror://sourceforge/group-office/${P}.tar.gz
- mirror://sourceforge/group-office/GO-theme-crystal-1.93.tar.gz"
-RESTRICT="nomirror"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa "
-
-DEPEND="virtual/php
- dev-db/mysql"
-
-webapp-detect || NO_WEBSERVER=1
-
-pkg_setup() {
- webapp-pkg_setup "${NO_WEBSERVER}"
- einfo "Installing into ${ROOT}${HTTPD_ROOT}."
-}
-
-src_unpack() {
- unpack ${A}
- unpack GO-theme-crystal-1.93.tar.gz
-}
-
-src_install() {
- webapp-mkdirs
-
- local DocumentRoot=${HTTPD_ROOT}
- local destdir=${DocumentRoot}/${PN}
-
- mkdir -p ${D}${destdir}
- mv ${WORKDIR}/crystal ${S}/themes
- cd ${S}
- dodoc CHANGELOG DEVELOPERS FAQ INSTALL RELEASE README.ldap TODO TRANSLATORS
- rm -rf CHANGELOG FAQ INSTALL README.ldap TODO TRANSLATORS
-
- cp -r . ${D}${destdir}
-
- # Fix permissions
- find ${D}${destdir} -type d | xargs chmod 755
- find ${D}${destdir} -type f | xargs chmod 644
-}
-
-pkg_postinst() {
- einfo "Follow the instructions at /usr/share/doc/${PF}/INSTALL"
- einfo "to complete the install. You need to add MySQL users"
- einfo "and configure ${PN}"
- einfo ""
- einfo "Please make sure your php settings have"
- einfo "register_globals = On"
- einfo ""
-}
diff --git a/dev-php/groupoffice/groupoffice-1.94.ebuild b/dev-php/groupoffice/groupoffice-1.94.ebuild
deleted file mode 100644
index 44df656ec459..000000000000
--- a/dev-php/groupoffice/groupoffice-1.94.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/groupoffice/groupoffice-1.94.ebuild,v 1.4 2004/01/08 08:40:44 robbat2 Exp $
-
-inherit webapp-apache
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Group-Office is a powerfull modular Intranet application framework. It runs *nix using PHP and has several database support."
-HOMEPAGE="http://group-office.sourceforge.net/"
-SRC_URI="mirror://sourceforge/group-office/${P}.tar.gz
- mirror://sourceforge/group-office/GO-theme-crystal-1.93.tar.gz"
-RESTRICT="nomirror"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa "
-
-DEPEND="virtual/php
- dev-db/mysql"
-
-webapp-detect || NO_WEBSERVER=1
-
-pkg_setup() {
- webapp-pkg_setup "${NO_WEBSERVER}"
- if [ -d ${HTTPD_ROOT}/${PN} ] ; then
- ewarn "You need to unmerge your old ${PN} version first."
- ewarn "${PN} will be installed into ${HTTPD_ROOT}/${PN}"
- ewarn "directly instead of a version-dependant directory."
- die "need to unmerge old version first"
- fi
-
- einfo "Installing into ${ROOT}${HTTPD_ROOT}."
-}
-
-src_unpack() {
- unpack ${A}
- unpack GO-theme-crystal-1.93.tar.gz
-}
-
-src_install() {
- webapp-mkdirs
-
- local DocumentRoot=${HTTPD_ROOT}
- local destdir=${DocumentRoot}/${PN}
-
- mkdir -p ${D}${destdir}
- mv ${WORKDIR}/crystal ${S}/themes
- cd ${S}
- dodoc CHANGELOG DEVELOPERS FAQ INSTALL RELEASE README.ldap TODO TRANSLATORS
- rm -rf CHANGELOG FAQ INSTALL README.ldap TODO TRANSLATORS
-
- cp -r . ${D}${destdir}
-
- cd "${D}/${HTTPD_ROOT}"
- chown -R "${HTTPD_USER}:${HTTPD_GROUP}" ${PN}
- # Fix permissions
- find ${D}${destdir} -type d | xargs chmod 755
- find ${D}${destdir} -type f | xargs chmod 644
-}
-
-pkg_postinst() {
- einfo "Follow the instructions at /usr/share/doc/${PF}/INSTALL"
- einfo "to complete the install. You need to add MySQL users"
- einfo "and configure ${PN}"
-}
diff --git a/dev-php/groupoffice/groupoffice-1.95.ebuild b/dev-php/groupoffice/groupoffice-1.95.ebuild
deleted file mode 100644
index cd19522da4f7..000000000000
--- a/dev-php/groupoffice/groupoffice-1.95.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/groupoffice/groupoffice-1.95.ebuild,v 1.1 2004/01/20 23:53:50 mholzer Exp $
-
-inherit webapp-apache
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Group-Office is a powerfull modular Intranet application framework. It runs *nix using PHP and has several database support."
-HOMEPAGE="http://group-office.sourceforge.net/"
-SRC_URI="mirror://sourceforge/group-office/${P}.tar.gz
- mirror://sourceforge/group-office/GO-theme-crystal-1.93.tar.gz"
-RESTRICT="nomirror"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa"
-
-DEPEND="virtual/php
- dev-db/mysql"
-
-webapp-detect || NO_WEBSERVER=1
-
-pkg_setup() {
- webapp-pkg_setup "${NO_WEBSERVER}"
- if [ -d ${HTTPD_ROOT}/${PN} ] ; then
- ewarn "You need to unmerge your old ${PN} version first."
- ewarn "${PN} will be installed into ${HTTPD_ROOT}/${PN}"
- ewarn "directly instead of a version-dependant directory."
- die "need to unmerge old version first"
- fi
-
- einfo "Installing into ${ROOT}${HTTPD_ROOT}."
-}
-
-src_unpack() {
- unpack ${A}
- unpack GO-theme-crystal-1.93.tar.gz
-}
-
-src_install() {
- webapp-mkdirs
-
- local DocumentRoot=${HTTPD_ROOT}
- local destdir=${DocumentRoot}/${PN}
-
- mkdir -p ${D}${destdir}
- mv ${WORKDIR}/crystal ${S}/themes
- cd ${S}
- dodoc CHANGELOG DEVELOPERS FAQ INSTALL RELEASE README.ldap TODO TRANSLATORS
- rm -rf CHANGELOG FAQ INSTALL README.ldap TODO TRANSLATORS
-
- cp -r . ${D}${destdir}
-
- cd "${D}/${HTTPD_ROOT}"
- chown -R "${HTTPD_USER}:${HTTPD_GROUP}" ${PN}
- # Fix permissions
- find ${D}${destdir} -type d | xargs chmod 755
- find ${D}${destdir} -type f | xargs chmod 644
-}
-
-pkg_postinst() {
- einfo "Follow the instructions at /usr/share/doc/${PF}/INSTALL"
- einfo "to complete the install. You need to add MySQL users"
- einfo "and configure ${PN}"
-}