summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-04-08 17:08:29 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-04-08 17:08:29 +0000
commitc298b8b62d7921802c0e5ff0c60de22c678ad0c9 (patch)
tree4286b3d2160cea65877064fbc847f9fb57b7c724 /dev-python/guessit
parentBump to 0.7.4, update live ebuild, bug #505044. Thanks to Nikoli. (diff)
downloadgentoo-2-c298b8b62d7921802c0e5ff0c60de22c678ad0c9.tar.gz
gentoo-2-c298b8b62d7921802c0e5ff0c60de22c678ad0c9.tar.bz2
gentoo-2-c298b8b62d7921802c0e5ff0c60de22c678ad0c9.zip
Bump to 0.7.1, update live ebuild, bug #507126. Thanks to Nikoli.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'dev-python/guessit')
-rw-r--r--dev-python/guessit/ChangeLog10
-rw-r--r--dev-python/guessit/guessit-0.7.1.ebuild32
-rw-r--r--dev-python/guessit/guessit-9999.ebuild15
3 files changed, 47 insertions, 10 deletions
diff --git a/dev-python/guessit/ChangeLog b/dev-python/guessit/ChangeLog
index 041f9564b730..18bdc3bb26f7 100644
--- a/dev-python/guessit/ChangeLog
+++ b/dev-python/guessit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/guessit
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/guessit/ChangeLog,v 1.6 2013/12/14 15:27:01 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/guessit/ChangeLog,v 1.7 2014/04/08 17:08:29 maksbotan Exp $
+
+*guessit-0.7.1 (08 Apr 2014)
+
+ 08 Apr 2014; Maxim Koltsov <maksbotan@gentoo.org> +guessit-0.7.1.ebuild,
+ guessit-9999.ebuild:
+ Bump to 0.7.1, update live ebuild, bug #507126. Thanks to Nikoli.
14 Dec 2013; Tom Wijsman <TomWij@gentoo.org> guessit-9999.ebuild:
Test fixes in live ebuild; proxied commit for Nikoli, fixes bug #494242.
diff --git a/dev-python/guessit/guessit-0.7.1.ebuild b/dev-python/guessit/guessit-0.7.1.ebuild
new file mode 100644
index 000000000000..b3c1a67b9e56
--- /dev/null
+++ b/dev-python/guessit/guessit-0.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/guessit/guessit-0.7.1.ebuild,v 1.1 2014/04/08 17:08:29 maksbotan Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="library for guessing information from video files"
+HOMEPAGE="http://guessit.readthedocs.org https://github.com/wackou/guessit https://pypi.python.org/pypi/guessit"
+SRC_URI="https://github.com/wackou/guessit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/babelfish-0.5.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.14[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/guessit/guessit-9999.ebuild b/dev-python/guessit/guessit-9999.ebuild
index 92ae3125d7af..4ca5e15e6be0 100644
--- a/dev-python/guessit/guessit-9999.ebuild
+++ b/dev-python/guessit/guessit-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/guessit/guessit-9999.ebuild,v 1.2 2013/12/14 15:27:01 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/guessit/guessit-9999.ebuild,v 1.3 2014/04/08 17:08:29 maksbotan Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3} )
EGIT_REPO_URI="https://github.com/wackou/guessit.git"
-inherit distutils-r1 git-2
+inherit distutils-r1 git-r3
-DESCRIPTION="Library for guessing information from video files"
+DESCRIPTION="library for guessing information from video files"
HOMEPAGE="http://guessit.readthedocs.org https://github.com/wackou/guessit https://pypi.python.org/pypi/guessit"
LICENSE="LGPL-3"
@@ -17,17 +17,16 @@ KEYWORDS=""
IUSE="test"
RDEPEND="
- >=dev-python/babelfish-0.4.1[${PYTHON_USEDEP}]
- dev-python/stevedore[${PYTHON_USEDEP}]
+ >=dev-python/babelfish-0.5.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.14[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? (
- dev-python/nose[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
)
dev-python/setuptools[${PYTHON_USEDEP}]
"
python_test() {
- esetup.py nosetests
+ esetup.py test
}