summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2014-08-13 00:23:06 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2014-08-13 00:23:06 +0000
commitefa1633032be46a45f6e7fa19d9ac07979706c28 (patch)
tree5d46ceb91d9d59638c0ad67a9ecae4b727ec1cdb /games-simulation/fgrun/fgrun-3.0.0.ebuild
parentbump; add pypy support, fix fix to qa build issue, thanks to Arfrever for the... (diff)
downloadgentoo-2-efa1633032be46a45f6e7fa19d9ac07979706c28.tar.gz
gentoo-2-efa1633032be46a45f6e7fa19d9ac07979706c28.tar.bz2
gentoo-2-efa1633032be46a45f6e7fa19d9ac07979706c28.zip
Version bump, remove old, exported from git tag 3.0.0-final. Fixes bug 436600.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key B1E955DB)
Diffstat (limited to 'games-simulation/fgrun/fgrun-3.0.0.ebuild')
-rw-r--r--games-simulation/fgrun/fgrun-3.0.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-simulation/fgrun/fgrun-3.0.0.ebuild b/games-simulation/fgrun/fgrun-3.0.0.ebuild
new file mode 100644
index 000000000000..6e80f7b7c669
--- /dev/null
+++ b/games-simulation/fgrun/fgrun-3.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-3.0.0.ebuild,v 1.1 2014/08/13 00:23:06 reavertm Exp $
+
+EAPI=5
+
+inherit games cmake-utils
+
+# Exported from git tag 3.0.0-final
+MY_PN=fg-fgrun
+MY_PV=e13e42811239008fded7685d8f2311bb571f6a58
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="A graphical frontend for the FlightGear Flight Simulator"
+HOMEPAGE="http://sourceforge.net/projects/fgrun"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls"
+
+COMMON_DEPEND="
+ >=dev-games/openscenegraph-3.0.1
+ sys-libs/zlib
+ x11-libs/fltk:1[opengl,threads]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-games/simgear-${PV}
+ >=dev-libs/boost-1.34
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=games-simulation/flightgear-${PV}
+"
+
+S=${WORKDIR}/${MY_PN}
+DOCS=(AUTHORS NEWS)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}
+ $(cmake-utils_use_enable nls)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ prepgamesdirs
+}